Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

1999 S80 Steering has no power assist at speed?

  #1  
Old 02-24-2009, 11:29 AM
Junior Member
Thread Starter
Join Date: Sep 2008
Posts: 12
Question 1999 S80 Steering has no power assist at speed?

I have a 99S80 T6. The wheel was rubbing on the trim and I fixed that. the trim was unclipped and loose. Now the power steering has almost no power at speed. When slow and parking it steers very easily. At any thing over 5MPH power steering is gone? Fluid is relatively clean and full. It does look a little dark but no Metal in fluid. Any suggetions would be appreciated. Thanks in advance.
 
  #2  
Old 02-24-2009, 06:48 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default

Maybe the pump or steering rack is bad.
 
  #3  
Old 02-25-2009, 12:10 PM
Junior Member
Thread Starter
Join Date: Sep 2008
Posts: 12
Default

Any way to tell which is bad? Id hate to replace both. I added some lucas steering additive and it did free up a hair if that means anything.
 
  #4  
Old 02-25-2009, 07:41 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default

Well if you can see the fluid moving around in the bottle then the pump should be working fine.

Maybe have someone rev it up and check for fluid movement.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
lionhearted1
Volvo S60 & V60
0
04-07-2012 04:47 PM
nextproject
Volvo S60 & V60
0
06-20-2009 06:41 PM
m_schiff83
Volvo S60 & V60
3
08-10-2007 05:06 PM


Thread Tools
Search this Thread
Quick Reply: 1999 S80 Steering has no power assist at speed?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.