Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

1999 S80 T6 Instrument Cluster Quits Working

  #1  
Old 11-16-2005, 10:41 PM
Thread Starter
Join Date: Nov 2005
Posts: 10
Default 1999 S80 T6 Instrument Cluster Quits Working

We have a 1999 s80T6. The computer gave signals of ABS and STC service and the instrument cluster quit working. I parked the car and restarted and all went back to normal. I sent the ABS module to the rebuild shop in FL for $75 as you all probably know. We re-installed it last week. No problems until today when the same problems re-occured. I am so frustrated. I do not know whose at fault. Is it the rebuilder or was it another problem from the start?
 
  #2  
Old 11-16-2005, 10:58 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: 1999 S80 T6 Instrument Cluster Quits Working

Have you called and talked to the rebuilder yet?

I have read on a couple of sites that not all Modules can be fixed.
 
  #3  
Old 11-16-2005, 11:04 PM
Thread Starter
Join Date: Nov 2005
Posts: 10
Default RE: 1999 S80 T6 Instrument Cluster Quits Working

I will do this first thing tomorrow morning. I can not wait to call and I will update you all. Do you think it is something else other than the ABS module that triggers this problem?
 
  #4  
Old 11-16-2005, 11:12 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: 1999 S80 T6 Instrument Cluster Quits Working

It is possible but remember the ABS module is an inline computer.It something happens with it could also cause many other problems.

Somewhat easy way to Explain how the system in the newer cars work.

EXAMPLE: Remember the old time christmas lights? What happens If one bulb goes out a ton of other ones do to from one bad bulb.

Thats kind of how (Easy explination) system works.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
SB245
Volvo 240, 740 & 940
16
12-03-2015 12:54 PM
dom2248
Volvo 240, 740 & 940
5
03-04-2013 10:40 AM
gunnarsedley
Volvo XC70
4
09-25-2011 08:58 AM
autobeef
Volvo V40
2
10-17-2007 12:00 PM


Thread Tools
Search this Thread
Quick Reply: 1999 S80 T6 Instrument Cluster Quits Working


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.