Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

1999 S80 T6 Washer Pump Does not work

  #1  
Old 12-01-2009, 06:22 AM
Senior Member
Thread Starter
Join Date: Dec 2008
Location:
Posts: 452
Exclamation 1999 S80 T6 Washer Pump Does not work

Went to use the washer fluid and it was coming on intermittent two days ago, today its not working at all, im not sure if the headlights are getting water but i cannot hear the pump working like i always did

wipers still move perfect on windshield and headlights, but i heard there are TWO WASHER PUMPS; one for windshield, one for headlights, how do i know which one is which?

So my guess is this is most likely the washer pump ? i can get it for $40.95 CAN+TAX , where is it located and how do i replace it ??? please help its snowing outside

PS: found this info on some valve that splits water between headlights and windshield
https://volvoforums.com/forum/showth...ghlight=washer
how har back is it from the grille ?
 

Last edited by andrei3333; 12-01-2009 at 06:50 AM.
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Volverine
General Volvo Chat
2
02-21-2015 05:32 AM
audiotx
Volvo V40
1
09-13-2012 07:52 PM
vy22
Volvo S80
2
03-01-2008 11:31 PM
mtidwell
Volvo 850
1
05-02-2006 09:15 PM
shinmoore
Volvo 240, 740 & 940
1
10-17-2005 09:35 PM


Thread Tools
Search this Thread
Quick Reply: 1999 S80 T6 Washer Pump Does not work


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.