Go Back  Volvo Forums - Volvo Enthusiasts Forum > Volvo Vehicles > Volvo S80
Reload this Page >

2.9 ticking/poor idle after compression test performed

Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

2.9 ticking/poor idle after compression test performed

  #1  
Old 01-05-2014, 11:01 AM
Junior Member
Thread Starter
Join Date: Jan 2014
Posts: 2
Default 2.9 ticking/tapping sound after compression test performed

First just wanted to say I've been reading here awhile and finally started an active account. Hope to be able to contribute where possible.

For now, I have a question I hope someone has come across before.

2000 S80, 2.9L. Was running good, but I have a coolant issue that I wasn't sure if it was the overflow tank letting in air or the engine, so I pulled the coils and plugs and ran a compression test. Compression was fair, 145, 140, 130, 120, 120, 140 or so. Nothing too alarming. So I put the spark plugs back in, coils back in, hook it up, and after firing it back up the engine is ticking / tapping. I double checked that all coils are seated good and that they were hooked up to the proper wires. I believe #5 is the one that has the electrical feed towards the firewall.

If I unplug each coil pack, the engine responds accordingly with sluggishness, indicating that every coil/plug is firing.

Any ideas on what could have gone wrong here?

My steps for compression test involved unplugging all coils so the engine would not fire. Could this have harmed ignition in any way? I had forgotten to kill the fuel.

Hoping timing did not slip.

Thanks for any tips or guidance.
 

Last edited by Timmay2; 01-05-2014 at 11:41 AM.
  #2  
Old 01-06-2014, 10:16 PM
Junior Member
Thread Starter
Join Date: Jan 2014
Posts: 2
Default

Still baffled how pulling the plugs and cranking the engine over caused the engine to start sounding like a diesel. No low oil pressure indicator either. Little nervous about playing with timing, I've only worked on non-interference before.

Assuming my oil may have gotten a bit fuel diluted for my forgetfulness in disconnecting the fuel, I'm going for a fresh oil change tomorrow.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
qstyle
Volvo 240, 740 & 940
11
02-17-2009 11:57 PM
wheelsup
Volvo 850
5
02-13-2009 09:58 AM
burnferris
Volvo V70
9
12-15-2008 09:53 AM
CrazyCabbie
Volvo 850
1
02-10-2008 08:34 PM
rp850
Volvo 850
1
01-20-2006 02:17 AM


Thread Tools
Search this Thread
Quick Reply: 2.9 ticking/poor idle after compression test performed


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.