Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

2000 T6 not starting

  #1  
Old 11-21-2010, 09:32 PM
Junior Member
Thread Starter
Join Date: Nov 2010
Posts: 1
Default 2000 T6 not starting

I have a 2000 S80 T6 that blows the "engine control unit injectors" fuse every time I try to start it. It started a week ago and when I changed the fuse it started fine for a few times, then it started blowing the fuse more often and now it blows it every time. When I could get it started it seemed to run like normal. Anybody have any ideas on what the problem might be?
Thanks,
KRIS
 
  #2  
Old 11-22-2010, 02:04 PM
Member
Join Date: Dec 2009
Posts: 70
Default

you obviously have a short somewere. I would look inside the owners manual to see which items are on that circuit. If it is only the computer and/or fuel injectors then I would suspect a short in either of those. The injectors are fairly easy to test with a multi meter. I would start there.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
stodd379
Volvo S40
1
05-01-2016 01:33 AM
clp29445
Volvo S40
3
05-01-2016 01:27 AM
dutch connection
Volvo V40
8
11-10-2009 02:14 PM
pikey
Volvo 240, 740 & 940
2
05-10-2007 01:34 PM


Thread Tools
Search this Thread
Quick Reply: 2000 T6 not starting


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.