Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

2001 S80 2.9l continues to crank but doesnt turn on

  #1  
Old 12-19-2017, 08:42 PM
Junior Member
Thread Starter
Join Date: Dec 2017
Posts: 8
Default 2001 S80 2.9l continues to crank but doesnt turn on

Before i start i just want to confess i searched everything about these S80s regarding starting issues and tried everything i could think of.

Problem: The car only cranks but doesnt catch and start. It continues to crank for however long i want it to crank. but nothing else. That rules out the starter

Things ive done
-Checked for spark. With the coilpack out i checked to see if i could see it arching to the flat head i had by it... saw a faint spark. Am i suppose to see something brighter?
-Replaced spark plugs - Didnt help
-Replaced Camshaft sensor (was getting P0014 and found it might be caused by that) Didnt help much
-Replaced Crank sensor - Still doesnt start
-Checked the fuel pressure at the rail and say ~50psi when the pumps are priming.
-Checked all fuses in the engine bay and the ones in the trunk. Looked good.
-Cleaned the electronic trottlebody since it was filthy. and made sure there wasnt any crazy oil build up. I replaced the oil canister some 30k miles ago.
-Timing belt and other pulleys/belts replaced maybe 5k miles ago.

What else should i check for?

Any help would be appreciated
 
  #2  
Old 12-20-2017, 04:17 PM
Senior Member
Join Date: Aug 2016
Posts: 114
Default

Check that the ECM is getting powered, It could maybe be the immobilizer. You`ve checked most of what I would think it could be. For sure disconnect the battery for 30 mins and try that.
 
  #3  
Old 12-20-2017, 10:59 PM
Junior Member
Thread Starter
Join Date: Dec 2017
Posts: 8
Default

Originally Posted by thommykent View Post
Check that the ECM is getting powered, It could maybe be the immobilizer. You`ve checked most of what I would think it could be. For sure disconnect the battery for 30 mins and try that.

How do you check if the ECM is getting power? read the pinouts?

I was thinking it could be the immobilizer however im not getting an immobilizer message on the dash and the car turns. oh and ive tried disconnecting the battery. I actually had it out of the car (charging) since i ended up draining much of the battery cranking it.

Update: I checked for spark again, this time all 6 coil packs and it seems like im getting weak spark on 1 or 2 of the coilpacks and no spark on one. Will need to check again once i charge the battery since it was weak again from all the cranking.
 
  #4  
Old 12-20-2017, 11:33 PM
Senior Member
Join Date: Aug 2016
Posts: 114
Default

Just suggestions, don`t know answers
 
  #5  
Old 12-29-2017, 01:02 AM
Junior Member
Thread Starter
Join Date: Dec 2017
Posts: 8
Default

So good news sort off... The car starts up like normal... Not sure how or what happened but it works and is drivable..

Current cell code shoes p0011 but not sure how legit it is since I have a cheap Bluetooth scanner.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rspi
Volvo 850
5
12-10-2011 10:58 PM
Nunez0524
Volvo S40
0
04-22-2011 09:55 AM
Sweet T5R
Volvo 850
13
02-26-2010 06:35 PM
glt93
Volvo 850
1
07-09-2007 07:05 AM


Thread Tools
Search this Thread
Quick Reply: 2001 S80 2.9l continues to crank but doesnt turn on


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.