Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

2009 Left stranded

  #1  
Old 08-10-2013, 06:28 PM
Member
Thread Starter
Join Date: Jul 2012
Location: Michigan
Posts: 40
Default 2009 Left stranded

Today when running errands with my whole family my 2009 S80 stalled- the battery light came on about 2 miles and then all the lights saying everything was shutting down and then nothing. Message on the console said low battery-

Car would turn over for about 45 seconds and then die, called a wrecker, as long as the car was connected, it would run, as soon as it disconnected, it died.

Battery is about 2 months old along with the altenator as well...

Not sure now....
 
  #2  
Old 08-10-2013, 07:56 PM
Senior Member
Join Date: Mar 2013
Location: Los angeles
Posts: 806
Default

probably the anti tamper sensor on the radiator. it runs off of the same network (LIN network) as the alternator.
 
  #3  
Old 08-11-2013, 08:04 AM
Member
Thread Starter
Join Date: Jul 2012
Location: Michigan
Posts: 40
Default

OK - never heard of that- curious, even when looking around for possible answers, apprentatly I got a lemon... No one is having the issues I am with my S80
 
  #4  
Old 08-11-2013, 10:45 AM
Senior Member
Join Date: Mar 2013
Location: Los angeles
Posts: 806
Default

yeah i think your best bet would be to either take it to someone you know that has vida or a dealership. if it is the anti tamper decive then they just came out with an ecm upgrade to fix that.
 
  #5  
Old 08-11-2013, 12:02 PM
Member
Thread Starter
Join Date: Jul 2012
Location: Michigan
Posts: 40
Default

is that hardware or software?
 
  #6  
Old 08-11-2013, 12:09 PM
Senior Member
Join Date: Mar 2013
Location: Los angeles
Posts: 806
Default

software. if that is the problem. thats supposed to fix the problem but if it doesnt you may need a new radiator
 
  #7  
Old 08-12-2013, 06:27 PM
Member
Thread Starter
Join Date: Jul 2012
Location: Michigan
Posts: 40
Default

A new radiator? Wow, OK....

So far the dealer has told me new Altenator, this is the third since 4/17/13
 
  #8  
Old 11-03-2014, 08:48 AM
Junior Member
Join Date: Oct 2014
Posts: 1
Default

Originally Posted by damien360 View Post
yeah i think your best bet would be to either take it to someone you know that has vida or a dealership. if it is the anti tamper decive then they just came out with an ecm upgrade to fix that.
Can you tell me any more info on the ECM UPGRADE? I have a 2010 S80 3.2 that had CEL twice for U0286 - Lost Communication with Radiator Anti Tamper Device.
What is the fix? ECM Link?

THANKS!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
vpatrol
Volvo 850
12
04-28-2014 09:25 PM
MomJulie
General Volvo Chat
2
02-13-2011 07:36 PM
wendy
Volvo XC70
6
06-03-2009 03:16 PM
placer61
Volvo S70
8
11-18-2008 08:05 PM
mattad
Volvo 240, 740 & 940
0
08-31-2004 11:52 AM


Thread Tools
Search this Thread
Quick Reply: 2009 Left stranded


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.