Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

99' S80 6cylinder electrical issues-no start

  #1  
Old 04-09-2015, 10:39 AM
Junior Member
Thread Starter
Join Date: Apr 2015
Posts: 1
Default 99' S80 6cylinder electrical issues-no start

Hello everybody! I'm an auto tech from columbus, oh. I was hoping someone on this forum would be able to help me trouble shoot this 99 volvo s80 im working on.

So.... customer had the vehical towed in. She was driving down the highway around 65mph when her dash told her the abs failure occured and to stop the car. So she did and shut it off. After a few mins she tried to restart the car and it would not crank. This is when she had it towed to us.

When the car arrived I put a battery charger on it. When i turn the key to the on position the head lights and tail lights and turn signals start flashing, all the relays under the dash are continues clicking, the dash lights up and the display shows srs failure, abs failure, the red ! is on, and after about 5 sec the dash will die and only after it dies the check engine light comes on. I have tried scanning it and no codes.

When I tried to crank it the power comes and goes at the same rate as the headlights strobing and relay's clicking. Ive put my power probe to the solinoid wire on the starter and it will crank as it is suppost to but still no start. I have tried looking for a broken ground and even cleaned the ones i have found. The battery is in good shape and holds its charge and terminals are clean and tight. I tried swapping the computers under the hood but had no change so I put back in the originals. I thought maybe the ignition switch could be bad? All the accesories are not affected by this problem. The radio, climate control, windows all work fine. I have searched forums for anyone having the same problem but no luck. I will post a video this evening showing the symtoms but any feed back would be highly appreciated! Thanks!!!
 
  #2  
Old 05-18-2015, 08:07 PM
Junior Member
Join Date: Jul 2009
Location: Sacramento, Ca
Posts: 5
Default

I had the same problem and symptoms on an 1999 S-80 I HAD. They are buggy to say the least. The flashing lights you describe are symptomatic of the anti-theft system kicking in. I found a bad ground had fooled the system into thinking it was being bypassed and therefore, stolen. You should find 3-4 black ground wires under the hood near the strut tower. Right side I think. It turns out these are the grounding wires for the computer. Check the resistance. If not that, the ABS computers are infamously faulty. Good luck.
 
  #3  
Old 09-07-2015, 06:32 AM
Junior Member
Join Date: Sep 2015
Posts: 1
Default

Hi. I have that exact same car with that exact same problem over here in Sweden. Have checked all ground wires, checked all positive connections I can find and the battery are new but nothing have helped so far...
Did you find a solution for that car you working on?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Nathan Ashley
Volvo S80
2
09-02-2014 12:28 AM
BradF80
Volvo S80
2
10-07-2013 10:13 AM
team2jnd
Volvo S80
7
01-29-2012 06:16 AM
dewrat
Volvo 240, 740 & 940
2
09-28-2005 07:14 PM


Thread Tools
Search this Thread
Quick Reply: 99' S80 6cylinder electrical issues-no start


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.