Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

AM radio bad ground?

  #1  
Old 04-08-2008, 07:19 PM
Thread Starter
Join Date: Dec 2007
Posts: 15
Default AM radio bad ground?

So lately I've taken to driving with one hand, because the other is constantly on the rear defrost button...

Whenever I'm listening to AM radio (and that is almost 100% of the time, thank god for sports talk radio stations), static and/or interference keep breaking in whenever I go over a bump, dip, pothole, or just general driving... It often creates a "warbly" sound to the radio, that is only solved by turning on or off the defrost several times. It's not distance or signal strength, I'm only 20 miles away from a very strong signal that is clear as day until I hit a bump.

Each time it is turned on/off the static gets a little less, sometimes dissipating on the first click, other times taking 5 to 6... I thought perhaps faulty ground somehwere, but if that was the case then shouldn't this phenomenon be affecting the FM radio as well? Because it doesn't.... FM is perfectly clear as it should be...

On a related front, as I'm stopping or accelerating, I will get kind of a low beep sound around 10 mph, it seems somewhat related to shifting from first to second gear, again some sort of interference. I haven't seen any posts on these forums with a similar problem, has anyone experienced this, and what was the solution? Thanks for any suggestions, I'll try them all, this is a huge frustration/annoyance...
 
  #2  
Old 04-15-2008, 03:55 PM
Thread Starter
Join Date: Dec 2007
Posts: 15
Default RE: AM radio bad ground?

Nobody has any thoughts? I'm clueless on this too but I'd rather not take it in, I'm pretty good with auto electronics once I know what the problem is, I just can't diagnose what would do this...
 
  #3  
Old 04-15-2008, 07:06 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: AM radio bad ground?

It might be a bad gound on the antenna Amp in the C-pillar on the drivers side.
There was many Tech Net notes and am reception for S80's (Actually to many to remember)
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
hold-fast
Volvo 260, 760 & 960
1
12-22-2013 08:22 PM
dssing
Volvo 240, 740 & 940
6
02-02-2006 08:56 PM
kaz
Volvo S80
1
03-14-2005 05:49 PM
Cypress
Volvo S40
1
12-06-2004 03:17 PM
teamlfr
Volvo 850
1
03-07-2004 12:48 AM


Thread Tools
Search this Thread
Quick Reply: AM radio bad ground?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.