Go Back  Volvo Forums - Volvo Enthusiasts Forum > Volvo Vehicles > Volvo S80
Reload this Page >

Does not want to accelerate past 1400 RPM's, Volvo S80

Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

Does not want to accelerate past 1400 RPM's, Volvo S80

  #1  
Old 05-15-2014, 08:37 PM
Junior Member
Thread Starter
Join Date: May 2014
Posts: 3
Default Does not want to accelerate past 1400 RPM's, Volvo S80

ok so i replaced my pvc breather box 2 weeks ago i then cleaned the spark plugs and coils because some had oil in them from the oil leaks caused by backed up pcv then i put everything back together ran fine for 3 days then got a misfire #1 code so i took that area apart found some residue from cleaning it then re cleaned it and ran fine for a few more days then while driving out of no ware i lost ability to accelerate past about 1400 rpm ive now taken everything apart about 5 times to look for vacuum leaks torn boots missing hoses ect. found nothing i know everyone thinks its the etm but i did the diagnostics check and its seems to be operating fine i also have no cel lights no warning messages nothing i have also cleaned the map sensor and the maf sensor to no prevail and now i cant even get it to a volvo shop to have them look at it please help.
 

Last edited by rspi; 05-16-2014 at 02:08 AM.
  #2  
Old 05-15-2014, 09:07 PM
Junior Member
Join Date: Aug 2013
Posts: 12
Default

Could be that a coil pack went bad. You can't check them with a meter either. I would look into that first.
 
  #3  
Old 05-15-2014, 10:29 PM
Junior Member
Thread Starter
Join Date: May 2014
Posts: 3
Default

How do i check them then I tried unplugging one at a time to see if there is no difference and every time i unplugged one it made a difference
 
  #4  
Old 05-16-2014, 02:05 AM
rspi's Avatar
Administrator
Join Date: Mar 2009
Location: Albuquerque, NM
Posts: 15,762
Default

Have you had the car scanned for codes? There is a chance that you have a clogged catalytic converter.
 

Last edited by rspi; 05-16-2014 at 02:09 AM.
  #5  
Old 05-16-2014, 07:36 AM
Junior Member
Join Date: Aug 2013
Posts: 12
Default

Originally Posted by loball86 View Post
How do i check them then I tried unplugging one at a time to see if there is no difference and every time i unplugged one it made a difference
Unfortunately you need one good coil to swap in and out with the suspect ones. Start with the one that gave the misfire.
 
  #6  
Old 05-16-2014, 10:18 PM
Canesfan1992's Avatar
Junior Member
Join Date: Jan 2014
Posts: 24
Default

Sounds like a coil pack issue to me. First week after buying my car I had the same symptoms.. Low rpms won't accelerate past, 1400-1500 rpms. My check engine light was intermittently flashing though, which is the car's limp mode.
 
  #7  
Old 05-17-2014, 10:25 PM
Junior Member
Thread Starter
Join Date: May 2014
Posts: 3
Default

The local junk yard had a2.9 s80 are the coils interchangeable if so ill grab a couple and swap them around I also just found one of the 2 wires that connect the coolant temp sensor to the harness at the boot is severed think maybe that could be at fault? its new looks like the boot hit the timing belt
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
chopin123
Volvo C70
1
03-23-2014 11:00 AM
Pre5tig3
Volvo 850
3
11-18-2013 06:56 AM
Jroc1975
For Sale / Trade
0
10-28-2013 01:42 PM
dva94
Volvo S70
6
12-04-2012 07:31 PM


Thread Tools
Search this Thread
Quick Reply: Does not want to accelerate past 1400 RPM's, Volvo S80


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.