Go Back  Volvo Forums - Volvo Enthusiasts Forum > Volvo Vehicles > Volvo S80
Reload this Page >

Emission System Service Required, Code Pulled, HELP?

Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

Emission System Service Required, Code Pulled, HELP?

  #1  
Old 05-03-2006, 03:47 AM
Thread Starter
Join Date: Sep 2005
Location:
Posts: 17
Default Emission System Service Required, Code Pulled, HELP?

Hey so today I was on the freeway in my 99 T6, I started to pass someone when my car lost a lot of power and started to run like crap. The "Emission System Service Required" came on and the Check Engine light started to flash. The car runs fine as long as I don't gt on it but when I get on it the motor shacks and the car doesnt seem to move with much more power like the turbos arent working. So I pulled the code. it said Cyl. #6 misfired. So I cleared the code hoping it was just a glitch but as soon as I got onto the freeway the light came back on and the car runs like crap. Tech I know you have talked about the bad coils is this what it sound like to you? if so I know replacing it would be pretty easy, whats the typical cost for one of the coils? Also is it bad to drive the car if I keep out of the power and drive it like a grandma? Which one is Cyl. 6, far right or left on the motor?
 
  #2  
Old 05-03-2006, 08:35 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: Emission System Service Required, Code Pulled, HELP?

Yes it sounds like either a bad coil or bad plugs.
But I would change all the plugs and atleast that one coil.
On all cars with timing belts #1 is always by the timing belt.
So #6 would be on the right.

Not sure about Cost check out the post in the general section with Links to sites and check out some of the sites.
 
  #3  
Old 05-06-2006, 01:50 AM
Thread Starter
Join Date: Sep 2005
Location:
Posts: 17
Default RE: Emission System Service Required, Code Pulled, HELP?

ok so i pulled all the plugs, I put them in less them 6 months ago, when i changed them then i put in Bosch platinum plugs well, anyways so all the plugs looked ok so I swapped out the #6 ign. coil with the #5 coil and put in just regular plugs to see if that would do the trick and if not it would misfire on the #5 cyl. and I would know thats what I got to get. By the way the ign. coils are about $60 online. Anyways thats not needed in this case, the plugs must have dont the trick. the car runs great. I love the feel of fresh plugs! so thanks Tech for the help.
 
  #4  
Old 05-06-2006, 09:50 AM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: Emission System Service Required, Code Pulled, HELP?

Glad it is fixed.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
robingichuhi
Volvo S80
3
02-22-2017 04:34 PM
S80guy
Volvo S80
31
08-18-2014 07:18 PM
chrissygm
Volvo S60 & V60
1
09-30-2008 05:53 PM
mingster
Volvo S60 & V60
10
08-20-2006 11:23 AM
volvo888
Volvo V70
14
06-06-2006 09:12 PM


Thread Tools
Search this Thread
Quick Reply: Emission System Service Required, Code Pulled, HELP?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.