Go Back  Volvo Forums - Volvo Enthusiasts Forum > Volvo Vehicles > Volvo S80
Reload this Page >

low beam problems, aftermarket stereo system... please help!!!

Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

low beam problems, aftermarket stereo system... please help!!!

  #1  
Old 11-12-2010, 03:46 AM
Junior Member
Thread Starter
Join Date: Oct 2010
Location: Moldova; Cgisinau
Posts: 1
Unhappy low beam problems, aftermarket stereo system... please help!!!

Hi, one day i've decided to upgrade my stereo system... as it was done i added about 2000watt audio system, now i have issues with power. The problem is that my low beam lights won't start... At first when starting the car i had 2 wait 4 about 1 or 2 minutes 4 the lights to turn on after turning the switch, now they wouldn't start at all... At first i thought it's a dead battery, but the rest of the electonics works well, the high beam works perfect, the car starts perfect... can anyone help? BTW i own an european 1999 S80 2.0Turbo.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Volvo_Neps
1998-2000 model year V70
3
10-07-2013 10:28 PM
Froton
Volvo S60 & V60
0
12-18-2011 08:12 AM
Volvoguy505
Volvo 240, 740 & 940
4
09-11-2010 05:53 PM
manezes
Volvo S60 & V60
0
11-15-2009 09:57 PM
volvo40_2k
Volvo V40
0
07-28-2009 09:18 PM


Thread Tools
Search this Thread
Quick Reply: low beam problems, aftermarket stereo system... please help!!!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.