Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

My surging issue returns!!

  #1  
Old 12-01-2007, 07:35 AM
Thread Starter
Join Date: Feb 2007
Posts: 37
Default My surging issue returns!!

I have been trying to nail this down for a while on my car. So far I have put in new plugs, air filter and turbo control valve and the problem persists. It feels like the car is misfiring slightly, or maybe the ETM is adjusting or something. The best way for me to exemplify it acting up is putting it in manual mode and accelerating very slowly in 1. Once it hits 2500 rpm, the revs will bounce around even though I am keeping my foot steady on the pedal. Another funny sympton is if I shut it off and restart it like 5 min later, the problem may disappear until I shut it off again and then it comes back.

I have taken it to the dealer and they drove it, of course the said it ran fine and they couldn't get it to act up and charged me $115 bucks! They also found no codes stored in it at all.

I always run premium fuel, synthetic oil and I take good care of the car, but this little problem is really frustrating me!! I keep thinking it is the ETM, but maybe I am missing something?
 
  #2  
Old 12-01-2007, 08:51 AM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: My surging issue returns!!

I would make sure it is acting up and get the service manager to ride with you and show him what it is doing.
 
  #3  
Old 12-02-2007, 10:06 PM
Member
Join Date: Jun 2006
Posts: 50
Default RE: My surging issue returns!!

mine does the exact same thing, but it is much worst when the car is cold. could it have to do w/oxygen sensors?
 
  #4  
Old 12-03-2007, 06:32 AM
Member
Join Date: Nov 2007
Location:
Posts: 34
Default RE: My surging issue returns!!

have you cleaned the mass air meter wire lately?
 
  #5  
Old 12-03-2007, 06:51 AM
Thread Starter
Join Date: Feb 2007
Posts: 37
Default RE: My surging issue returns!!

Mine is actually better when it is cold, it gets worse once it warms up.

No I haven't cleaned the MAF, I was thinking about it though. The car has 130000 kms on it and it was replaced at 70000 kms according to the service records. I think I will give it a shot, it can't hurt?

 
  #6  
Old 12-03-2007, 07:31 AM
Member
Join Date: Nov 2007
Location:
Posts: 34
Default RE: My surging issue returns!!

i would definitelyclean itfor that many miles. Just make sure you use the mass air meter specific cleaner.Below is what i used. You will also need a security torx bit to pull out the element, i think it is a T-20 security.

http://us.st11.yimg.com/us.st.yimg.c..._1974_21322962
 
  #7  
Old 12-03-2007, 11:56 AM
Thread Starter
Join Date: Feb 2007
Posts: 37
Default RE: My surging issue returns!!

OK I will give it a try, I am not sure where I can find the CRC stuff around here. I have electrical contact cleaner, but you say that may cause problems?
 
  #8  
Old 12-03-2007, 12:10 PM
Member
Join Date: Nov 2007
Location:
Posts: 34
Default RE: My surging issue returns!!

I am not sure if that will cause problems or not (it is probably the same stuff and will work fine). You are mainly trying to avoid something that will leave a residue on the wires and eat up any plastic on the body of the MAF sensor itself. I just got done cleaning mine because the check engine light kept coming on and settingtwo mass airflow sensor codes and I thought i would try this first. So far I have over 100 miles and mulitple key cycles since I reset the code and no light yet. I am going to hook upmy computer today and see where my long term fuel trims are at. Before I cleaned they MAF sensor they were at 21.9%.
 
  #9  
Old 12-03-2007, 12:56 PM
Join Date: Dec 2007
Posts: 1
Default RE: My surging issue returns!!

Had a similar issue and was told by the dealer it was the boost control module. That seems to have taken care of the problem.
 
  #10  
Old 12-03-2007, 02:39 PM
Thread Starter
Join Date: Feb 2007
Posts: 37
Default RE: My surging issue returns!!

I have replaced the turbo control valve already and it didn't help.

The cleaner says it is safe on plastic and leaves no residue, so I am going to give it a shot. The previous owner of the car had it in dusty environments on many occasions so this could be the cause.
 
  #11  
Old 12-03-2007, 08:15 PM
Member
Join Date: Nov 2007
Location:
Posts: 34
Default RE: My surging issue returns!!

Well i checked my long term fuel trims today and in 100 miles they went from 21.9% to 18%. I will keep checking them periodically to hopefully see further improvement. Just thought I would put this information out there for everybody. I am just excited that 6 bucks worth of cleaner has prevented me from buying a MAF sensor and i am not seeing that annoying light as of now. And asa sidenote, my car did not display any driveability issues and the MAF sensor element looked fairly clean to the naked eye upon inspection. The check engine light is the only thing I ever experienced.
 
  #12  
Old 12-05-2007, 07:34 PM
Thread Starter
Join Date: Feb 2007
Posts: 37
Default RE: My surging issue returns!!

I cleaned the MAF, no luck. I will try to get it to act up at the dealer and I will see how it goes.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
strangedays
Volvo 850
11
11-12-2007 05:54 PM
Frodo
Volvo 240, 740 & 940
2
02-24-2007 02:48 PM
longship
New Members Area
1
02-17-2007 11:23 AM
simonh9
Volvo 850
12
10-09-2005 02:17 PM
wmclott
Engine & Internal
1
06-04-2005 04:55 PM


Thread Tools
Search this Thread
Quick Reply: My surging issue returns!!


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.