Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

S80, Loss of power taking off-70MPH

  #1  
Old 08-12-2010, 09:02 PM
Junior Member
Thread Starter
Join Date: Aug 2010
Posts: 11
Default S80, Loss of power taking off-70MPH

I have a 2000 Volvo S80 2.9 with 112,000 miles. It started that when I where to drive 60-70 mph it would loose power and feel like I was taking my foot of the gas. It got worse now sometimes when I'm just taking off from stop or cruising up to 50 there is a loss of power or nothing there when I hit the gas. One time I was driving at 40 and punched it half way, it took 6 seconds to take off.

I replace the air filter, fuel filter, and replaced the spark plugs. I did not gap them, someone told me that they may be the wrong ones(O Riley auto parts gave me these).

Does anyone have any ideas what might be wrong???

Also Brake, ABS, and Traction control light turn off and on all the time, along with message center saying service urgent. but everything seems fine.

PLEASE HELP. Reply here or email at [email protected]
 
  #2  
Old 08-12-2010, 09:30 PM
Junior Member
Join Date: Aug 2010
Location: California/Oregon
Posts: 4
Default

i just got a 99 s80 t6 , i would HIGHLY suggest the software upgrade. alot of times with the electronic problems the software upgrade is the problem, also there are a few recalls on the s80's so I would call Volvo asap and tell them you are the new owner of the car, they will ask for you VIN and if the recalls have not been done yet you will get them for FREE! Its a great deal. anyways the software upgrade was one of the recalls on mine, and it did wonders.

Volvos number is 1800 458 1552 just have your VIN ready and they will tell you if the recalls have been done on the car or not. email me for any questions, [email protected]
 
  #3  
Old 08-12-2010, 11:26 PM
Senior Member
Join Date: Nov 2005
Location: Burlington, ma
Posts: 1,129
Default

I ran into the abs, stc and brake light comming on, turned out to be a faulty abs module.

Loss of power thing was a throttle body issue - needed cleaning..
 
  #4  
Old 08-13-2010, 07:40 AM
Junior Member
Thread Starter
Join Date: Aug 2010
Posts: 11
Default

thanks guys, i will look into that stuff tonight
 
  #5  
Old 08-14-2010, 02:47 PM
Junior Member
Thread Starter
Join Date: Aug 2010
Posts: 11
Default

OK, I cleaned the throttle body today(which was not the easiest). I drove it down the road and seems that it helped it alot, but now my moon roof does not work WTF
 
  #6  
Old 08-15-2010, 01:52 PM
Junior Member
Join Date: Aug 2010
Location: California/Oregon
Posts: 4
Default

hey, alright well one of the recalls on my S80 (1999) was the throttle body, and it causing the car to go into "limp home" mode. I would try what I suggested before and call that number I gave you. That could be the case for yours, and if the recall hasnt been done on yours then you can get it for free. Another thing that is kind of interesting is when I got my car from the dealer about a week and a half ago, the moon roof didnt work. The dealer had it fixed with in 5 min...I could call the guy and ask for you what he did to fix it...I would assume it was just a fuse or something, but let me know if you got yours fixed yet, and if you havent I will call him and ask what was wrong with mine! Best of luck.
 
  #7  
Old 08-16-2010, 12:46 AM
Senior Member
Join Date: Nov 2005
Location: Burlington, ma
Posts: 1,129
Default

just hit the unlock//lock with the remote - for moon rooof, i've heard that it can help to make it work again.
 
  #8  
Old 08-16-2010, 07:58 AM
Junior Member
Thread Starter
Join Date: Aug 2010
Posts: 11
Default

yes it works now, cleaning the throttle body helped but did not fix entirely. I will be calling the dealership later today
 
  #9  
Old 08-19-2010, 08:45 PM
Junior Member
Thread Starter
Join Date: Aug 2010
Posts: 11
Default

ok guys, I cleaned the ETM, changed the plugs, fuel filter, air filter and ran fuel injector cleaner through it twice. Still this problem persists. I have called the dealership and there are no recalls and no software updates need(the guy before me did it in 2006).....Does anyone know whats going on here, probably going to bring it in next week, unless I hear otherwise.

I will let people know what they come up with.
 
  #10  
Old 08-20-2010, 10:22 PM
Member
Join Date: Apr 2009
Location: Los Angeles,CA
Posts: 53
Default

Hi there,
Do you know if the valves were adjusted?On my old car the mechanic overtightened them and I was stalling and dying on every stop light.Took it to the dealer and they said that's why you don't let just any ol' shop to do the tricky,important stuff on your engine!
Hope this helpes..take care..
 
  #11  
Old 08-25-2010, 07:52 PM
Senior Member
Join Date: Mar 2007
Location:
Posts: 200
Default

Try this place to rebuild your abs box they did mine 2 years ago and it works great

http://www.bba-reman.com/abs.htm
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
S70driver
Volvo S70
6
05-30-2008 04:55 PM
Lab_Rodent
Volvo S80
2
11-03-2007 01:12 AM


Thread Tools
Search this Thread
Quick Reply: S80, Loss of power taking off-70MPH


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.