Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

So i changed the battery....

  #1  
Old 10-14-2013, 09:43 AM
akabond's Avatar
Senior Member
Thread Starter
Join Date: Nov 2010
Location: Texas
Posts: 434
Default So i changed the battery....

old battery was low ( but not dead) so i bought OEM from the dealer. Plus the old one lasted me like 7 years . anyways the reason i am posting that i was reading online and on youtube that before and after changing the battery one need to do some kind of calibration ( like turn the key on II position or open and close the sunroof couple of time etc) in order to reset the computer.
But when i read the owners manual on my 2006 S80 2.5T there was no mention about this at all.
Its just a simple remove the old one and put in new one
And thats what i did with no problems. The car started up just fine and there was no problems in electronics in the car.
I was going to do a DIY but its actually pretty straight forward.
 
  #2  
Old 10-14-2013, 11:13 AM
Senior Member
Join Date: Jul 2011
Posts: 194
Default

akabond, thanks for update. I changed mine last month but soon after changing i am facing issues...like some times when my car is warm enough or 100 KM drive after...though I changed exactly the way you did......but when I turn off the car and start again, my RPM zooms up and down....any suggestions?
 
  #3  
Old 10-14-2013, 11:47 AM
akabond's Avatar
Senior Member
Thread Starter
Join Date: Nov 2010
Location: Texas
Posts: 434
Default

looks like yours is a different year and engine. did you read the manual about any calibration and/or talked to the dealer just to get their opinion about replacing battery. i had to ask the dealer too when i was there to get the new battery and they 1st asked what kind of engine. so maybe that might be a factor.
But you said after a month. so could be something else. You only mentioned that the issue is rpm goes up and down. that could be some minor electronic signal . mine did that too but on my old battery and it was random. With the new one it stopped.
As you know older S80s have lot of electrical problems
 
  #4  
Old 10-14-2013, 08:55 PM
Join Date: Jun 2011
Posts: 86
Default

I also just changed out the battery in our '06 S80 2.5T. I turned off the A/C system and the radio. The radio worked with no code needed and A/C blew cold air. No problems in over a week.
 
  #5  
Old 10-17-2013, 07:00 PM
Senior Member
Join Date: Jul 2011
Posts: 194
Default

We got winters here from few days its working fine, so I am sure either my Starter cables are culprit or Starter it self. Thanks.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Domas
Volvo S40
2
12-07-2007 10:01 AM
Raging Demon
Audio/Visual Electronics
1
06-14-2007 07:39 PM
patrickpar
Volvo S80
3
10-26-2006 11:17 AM
cava
Volvo 850
4
07-28-2006 05:39 PM


Thread Tools
Search this Thread
Quick Reply: So i changed the battery....


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.