Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

Tons of problems that all happend overnight!

  #1  
Old 11-10-2009, 11:10 AM
Junior Member
Thread Starter
Join Date: May 2009
Posts: 3
Angry Tons of problems that all happend overnight!

I have a Volvo S80 2.4L. This morning it started to stall at red lights and stall at increased exceleration. Telling me to "Dive slowly service urgent", Emmision Service Required", "Transmission Service Required", and "Bulb position Failure".
I do have a small gas leak due to a cracked tank but, its not noticable unless in traffic or stopped for long periods of time. Replaced the transmission 3yrs ago. Reading about coils.. could that be the problem. Please help I cant afford this right now! I just moved into a new house! The car is a 99 with 170K I just need it to be reliable for 1 1/2 more years . Also replaced radiator, radiator hose, struts, axels, battery 3 times, spark plugs, and Im sure there is more that I cant remember right now.
Thank you kindly in advance!
Jessica
 
  #2  
Old 11-10-2009, 12:19 PM
imhereftw's Avatar
Senior Member
Join Date: Jan 2009
Location: Maryland, USA
Posts: 179
Default

Probably not the best idea to be riding around with a cracked fuel tank.
 
  #3  
Old 11-10-2009, 01:06 PM
Junior Member
Thread Starter
Join Date: May 2009
Posts: 3
Default

I know, I just dont have the funds to fix my POS at this time. I did go to Autozone to have the codes pulled and this is what they gave me.
P1330
P0442
Any ideas?
 
  #4  
Old 11-10-2009, 10:51 PM
fs's Avatar
fs
fs is offline
Member
Join Date: Dec 2007
Location: Nor Cal
Posts: 62
Default

Originally Posted by doddj22 View Post
I know, I just dont have the funds to fix my POS at this time. I did go to Autozone to have the codes pulled and this is what they gave me.
P1330
P0442
Any ideas?

P1330 CVVT solenoid----Search the forums about this one

P0442 EVAP Emission Control System Leak (Small)----Gas tank leak you mentioned Ima thinking.

Bulb position Failure----more than likely one of the tail light bulbs is either burnt out..or just has a bad/loose connection.

For the other ones try searching for something bout the ABS module on here I think...
 
  #5  
Old 11-10-2009, 11:34 PM
blackbrick's Avatar
Senior Member
Join Date: Apr 2009
Location: Phoenix,Arizona
Posts: 448
Default

I found this on P1330
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
misterruby
Volvo S60 & V60
12
12-14-2018 09:48 AM
junkyardpower
New Members Area
1
05-27-2013 12:48 PM
davisrf
Volvo S60 & V60
4
04-08-2011 09:52 AM
egm8599
Volvo XC70
1
08-25-2010 05:50 PM
mbsjshad
Volvo S60 & V60
0
11-06-2009 03:56 PM


Thread Tools
Search this Thread
Quick Reply: Tons of problems that all happend overnight!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.