Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

Wierd Issue, Is it my FFuel Filter

  #1  
Old 12-05-2010, 10:49 PM
Junior Member
Thread Starter
Join Date: Jan 2010
Posts: 4
Default Wierd Issue, Is it my FFuel Filter

Start the car in the cold weather, but it's not a hard start or no start. Go to put my foot on the gas and the RPM's dip to maybe 500 before going to operating rpms. Has done this a few times now. Also noticed in my first mile of my drive tonight the RPM's dipped one time about 500 rpm's while car was warming up, no problems after the two I stated. I presume my fuel filter is the original(seeing as my brother only did like oil changes on the car). Car has a hair over 155K miles on it. Is my filter going bad? I have only now noticed this problem when it's cold outside also.
 
  #2  
Old 12-06-2010, 09:34 AM
Senior Member
Join Date: Dec 2006
Location:
Posts: 311
Default

Sounds more like an air mixture issue... check air intake and vac lines, then possibly on to the throttle body. From there, temp sensors, etc...
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
hmert7
Volvo S60 & V60
8
02-23-2014 08:01 PM
endneu913
Volvo 240, 740 & 940
2
10-13-2011 11:38 PM
91shelby
Volvo 850
12
05-29-2011 03:24 PM
A MAL3 NURSE
Volvo S80
0
03-10-2011 09:09 PM
bostongrun
Volvo 850
0
11-13-2010 03:19 PM


Thread Tools
Search this Thread
Quick Reply: Wierd Issue, Is it my FFuel Filter


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.