RADIO Not Working Blank - Volvo Forums - Volvo Enthusiasts Forum

Volvo XC90 This mid-sized SUV offers the driver and passengers Volvo luxury and quality with sport utility capability.
Sponsored by:
Sponsored by:

RADIO Not Working Blank

Reply

 
 
 
  #1  
Old 07-06-2012, 05:04 PM
Junior Member
Thread Starter
Join Date: Jul 2012
Posts: 2
Exclamation RADIO Not Working Blank

Ok so I unplugged my factory radio yesterday and when I plugged it back in the screen is now blank.

I can press the **** in twice and it will say "volvo premium sound" only for a few seconds and goes blank again.

I can get into the settings menu but thats all.... I NEED HELP



What I have done soo far to try to fix it

- I unhooked the car battery for a couple of hours

- I cycled the remote lock/unlock buttons

- I made sure all connections were in their proper places

- I checked fuses

- I left the car on overnight in acc.
 
Reply With Quote
  #2  
Old 07-09-2012, 01:41 PM
Junior Member
Thread Starter
Join Date: Jul 2012
Posts: 2
Default re: radio

Here is a picture of what I am getting...
 
Attached Thumbnails RADIO Not Working Blank-019.jpg  
Reply With Quote
  #3  
Old 07-10-2012, 12:29 PM
Junior Member
Join Date: Dec 2011
Posts: 5
Default

why did you unplug the radio in the first place?

I'm just guessing here but there may be some sort of security on the radio itself to prevent theft. BMW does that and you have to enter a special code for your radio to enable everything again after it's been unplugged from the car.

Be careful unplugging electronics... I've seen youtube videos about disassembling the factory radio and if you unplug a specific wire harness, you'll end up getting the airbag light turned on and have to get it reset by the dealer. Here's a link to the video: http://www.youtube.com/watch?v=QAzECToCF6M
 

Last edited by nsheffer; 07-10-2012 at 12:38 PM.
Reply With Quote
  #4  
Old 11-18-2017, 03:02 PM
Junior Member
Join Date: Nov 2017
Posts: 2
Default Following up

My car is doing that after unplugging the stereo today to remove a disc. Were you ever able to get a diagnosis? Much appreciated feed back!
 
Reply With Quote
  #5  
Old 12-16-2017, 11:29 AM
Junior Member
Join Date: Oct 2014
Posts: 7
Default

Originally Posted by Hollys3 View Post
My car is doing that after unplugging the stereo today to remove a disc. Were you ever able to get a diagnosis? Much appreciated feed back!
If you get an airbag code you can buy a scanner for about $125 and re set yourself.Other than that you have to go to a shop.Maybe somebody else can give a tip on not using a scan tool but I have had no luck otherwise.
 
Reply With Quote
  #6  
Old 08-09-2018, 06:02 PM
Junior Member
Join Date: Aug 2018
Posts: 2
Default

Originally Posted by mcd0minguez View Post
Ok so I unplugged my factory radio yesterday and when I plugged it back in the screen is now blank.

I can press the **** in twice and it will say "volvo premium sound" only for a few seconds and goes blank again.

I can get into the settings menu but thats all.... I NEED HELP



What I have done soo far to try to fix it

- I unhooked the car battery for a couple of hours

- I cycled the remote lock/unlock buttons

- I made sure all connections were in their proper places

- I checked fuses

- I left the car on overnight in acc.
I have some problem. What I wall do..?
 
Reply With Quote
  #7  
Old 08-09-2018, 06:05 PM
Junior Member
Join Date: Aug 2018
Posts: 2
Default

Originally Posted by mcd0minguez View Post
Ok so I unplugged my factory radio yesterday and when I plugged it back in the screen is now blank.

I can press the **** in twice and it will say "volvo premium sound" only for a few seconds and goes blank again.

I can get into the settings menu but thats all.... I NEED HELP



What I have done soo far to try to fix it

- I unhooked the car battery for a couple of hours

- I cycled the remote lock/unlock buttons

- I made sure all connections were in their proper places

- I checked fuses

- I left the car on overnight in acc.
I have some problem.. What I wall do .?
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
richardgrant
Volvo S40
1
04-28-2015 08:22 PM
Cefore
Volvo C70
14
05-03-2009 03:49 PM
fencerider
Volvo S80
3
02-21-2009 09:14 AM
malibu2
Volvo XC70
2
11-26-2007 11:05 PM
craddoce
Volvo S40
2
10-23-2007 04:57 PM


Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory