Sights N Sounds Post all of your video and sound clips here.

Thinking about installing a SC-816...

  #1  
Old 12-12-2011, 10:03 PM
rspi's Avatar
Administrator
Thread Starter
Join Date: Mar 2009
Location: Albuquerque, NM
Posts: 15,762
Default Thinking about installing a SC-816...

My daughters S70 had a very weak sounding SC-816 in it so I swapped in a SC-815 from a S90 and it really sounds good now. Looking at the specs, it says those radios have the same watts per channel in them, 4 x 25 but I tell you, there is no comparrison in the sound, the one from the S90 thumps.

So, someone suggested that the amp in the SC-816 was damaged. Anyway, I have a aftermarket single dim Pioneer with a cd player in it currently installed in my wagon. I'd like to get a tape player in it so I can listed to music from my phone and internet through the tape adapter. The T-5R's have a seperate power amp installed, suppose to be 160 watts. My guess is that is 40 watts per channel. They think that the external amp will over ride the internal amp when it's plugged in. I think I'm going to try to install it tomorrow.

Hopefully they did not damage the wire harness when they installed the Pioneer.
 
  #2  
Old 12-18-2011, 05:47 PM
rspi's Avatar
Administrator
Thread Starter
Join Date: Mar 2009
Location: Albuquerque, NM
Posts: 15,762
Default

Pulled the Pioneer and found a lot of stereo hook-up behind it. One set did run the Volvo head unit so I'm good to go. It looks like they wired the Pioneer into the Volvo harness. Still had an amp connection and it does thump like the Pioneer does.

The Pioneer is suppose to have 50w per channel and I believe the Volvo (Alpine) has 40w per channel but I could hardly tell the difference with those door speakers. I also thing the Volvo head unit as a little cleaner bass so I like it. I think the Pioneer has a better CD player but I really don't play CD's so that wont matter. Now I can play my phone through the tape adapter. Hurrah!!!
 
  #3  
Old 12-18-2011, 07:32 PM
rspi's Avatar
Administrator
Thread Starter
Join Date: Mar 2009
Location: Albuquerque, NM
Posts: 15,762
Default

When I installed the SC-811 I could only find 1 antenna wire. The unit has the 2 antenna holes in the back. Not sure if the other antenna wire was ever there in this '95 wagon. Can someone please pull their radio on a '95 wagon out and see if it has 2 antenna wire going into the back of the radio?
 
  #4  
Old 12-20-2011, 10:03 AM
swiftjustice44's Avatar
Super Moderator
Join Date: Aug 2008
Location: Dallas, TX
Posts: 2,581
Default

What? No one has done this yet? C'mon people...yank those radios and help Robert out!!
 
  #5  
Old 01-17-2012, 07:01 AM
Brick850's Avatar
Senior Member
Join Date: Dec 2011
Location: Adelaide, Australia
Posts: 445
Default

My 95 wagon only has one antenna wire, and only one hole on the stereo SC 811
 
  #6  
Old 01-17-2012, 07:55 AM
rspi's Avatar
Administrator
Thread Starter
Join Date: Mar 2009
Location: Albuquerque, NM
Posts: 15,762
Default

I guess they went to the 2 antenna wire arrangement in '96.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
olele
Audio/Visual Electronics
3
07-01-2009 06:53 PM
ekanenh
Volvo V70
1
06-04-2009 11:44 AM
dec1184
Volvo 850
3
04-09-2008 03:26 PM
halekai
Volvo V70
8
01-18-2008 08:59 AM
AaronD81
Audio/Visual Electronics
1
03-20-2006 07:55 PM


Thread Tools
Search this Thread
Quick Reply: Thinking about installing a SC-816...


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.