240 Fuel Pump Not Engaging on Igniton

  #1  
Old 01-28-2019, 07:09 PM
Junior Member
Thread Starter
Join Date: Jan 2019
Posts: 2
Default 240 Fuel Pump Not Engaging on Igniton

I have been having a problem with my 240 rarely starting, due to the fuel pump not coming on after turn key. Sometimes, but very rarely, I will hear the fuel pump whine for a second and then the car will start after I crank. I originally thought I had a defective pump and made the mistake of replacing it, followed by the in-tank fuel pump, and the fuel pump relay. The symptoms really seem to point to the fuel pump relay, but I already replaced it and I have seen no difference in performance. The signs point to something electrical but I have no experience diagnosing something like this. Any help is much appreciated,
Thanks
 
  #2  
Old 01-28-2019, 08:33 PM
Junior Member
Thread Starter
Join Date: Jan 2019
Posts: 2
Default

Ok so I did a really bad job of documenting my steps but here is an update (it's now working). I removed fuses 4 and 6 relating to the fuel pump and then accessed the fuel pump ground. I unscrewed the ground and did a quick cleaning of the connection, then screwed it back in. I went underneath the car and gave the power connections to the fuel pump a jiggle while I was at it. I tried the ignition on the car again and after multiple times of turning the key the fuel pump finally engaged. I had forgot to put the fuses back in so I did that and decided to try again, and for some reason it just started working. I assume the ground had a problem, even though there were no signs of corrosion or any debris messing up the contacts at all. Hopefully this helps someone else
 
  #3  
Old 01-29-2019, 04:43 PM
Former Moderator
Join Date: Oct 2010
Location: 37 North on the left coast
Posts: 9,995
Default

indeed, the pump only runs for about 1 second when you turn the key on then stops until the engine is cranked over... and when the engine stops turning, about 1 second later, the pump stop.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mkangrga
Volvo S70
5
06-25-2009 07:58 PM
sblaine
Volvo XC90
0
02-09-2009 12:03 PM
png
Volvo XC90
0
12-19-2008 01:17 PM


Thread Tools
Search this Thread
Quick Reply: 240 Fuel Pump Not Engaging on Igniton


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.