unknown culprit,,electronics - Volvo Forums - Volvo Enthusiasts Forum


Volvo 850 Made from 1993 to 1997, this Volvo line was available in both a wagon and a sedan, both with were graced with several trim levels.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 01-10-2008, 08:31 PM
Thread Starter
 
Join Date: Jan 2008
Posts: 1
Default unknown culprit,,electronics

got a 94 850,,just got her,,,,A fine looker,,,problem with stalling after semi warm,,will start right back ,,with one incident of hard starting back,,,first code reading was MAF and O2 ,,,cleared codes and run again,,,MAF code come up,,(121),,MAF connector terminal #2 indicated resistance,,.....figure the O2 code was from other malfunction,,,,Do I look toward the brain box or the MAF...how do you test a MAF sensor?....recent purchase from private stock,,,well maintained and serviced regularly by dealer,,,My research shows a special plug and adapter is needed to test the fuel ECM,,,if I needed one where do I look for it?.......Hoping this Is an easy fix but also know electrical and electronics can be a roll ya eyes ,grit ya teeth,sob ,,bit the the bullet....any input????THANX 4 any ..........AL
Reply With Quote
  #2  
Old 01-10-2008, 11:21 PM
JPN's Avatar
JPN JPN is offline
Senior Member
 
Join Date: Sep 2006
Location: IPS, MA
Posts: 5,387
Default RE: unknown culprit,,electronics

Welcome to the forum.

Most likely the MAF sensor has gone south. See attachment for testing procedure. If it is turbo it should have the OBD-II port in front of the shifter right under the coin holder. Also see: http://volvospeed.com/Repair/maf_secure.php


JPN

[IMG]local://upfiles/6892/64C89DD673A3486A934622FAD667EA09.jpg[/IMG]

[IMG]local://upfiles/6892/6510FF3171004AD4B5E521DED83322A7.jpg[/IMG]

[IMG]local://upfiles/6892/8CC2E879BE194D129107E62B83548004.jpg[/IMG]
Reply With Quote
  #3  
Old 01-11-2008, 09:42 AM
Psaboic's Avatar
Super Moderator
 
Join Date: Jan 2006
Location: SW, WA
Posts: 2,143
Default RE: unknown culprit,,electronics

Check the tightness of the MAF Connector. If that doesn't eliminate the problem, I would suspect the MAF itself is bad
Reply With Quote
  #4  
Old 01-11-2008, 07:35 PM
tech's Avatar
Administrator
 
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: unknown culprit,,electronics

A bad MAF could also throw O2 sensor codes.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Oil Leak S80 2001 - Cam plug cover possible culprit scooter101 Volvo S80 2 08-06-2010 02:49 PM
I think i found the culprit!!! chef Volvo 850 13 06-27-2008 08:39 PM
I hate loving my S80 but the electronics!!! mikeys Volvo S80 4 09-28-2006 12:43 PM
Electronics module problem? PawnEnpassant Volvo S60 & V60 2 08-20-2006 04:25 PM
Electronics or transimssion uncle Volvo V70 1 08-09-2006 09:49 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 10:09 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.