Possible fuse missing? - Volvo Forums - Volvo Enthusiasts Forum


Volvo C30 This compact hatchback gives a sporty feel without compromising versatility.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 05-05-2017, 04:32 PM
Junior Member
Thread Starter
 
Join Date: May 2017
Posts: 4
Default Possible fuse missing?

Came into a used 2009 C30 in the winter time, and didnt think to ask about the AC. Its getting warmer, so when I tried to turn it on, it didnt blow cold air. It also doesnt feel like its engaging, (no change in power whatsoever when switched on).
I thought I would try checking the easiest option, if the AC compressor fuse was blown. It appears ok, however, when I checked fuse 5, the "Climate Element", it is missing. Is that normal? I havent been able to find any photos online with that fuse missing.
My next step would be to order the missing fuse and replace to see if that helps, but I wasnt sure if that would cause an issue if its not supposed to be there in the first place?
Thanks for any advice.
Reply With Quote
  #2  
Old 05-07-2017, 07:54 PM
Member
 
Join Date: Jun 2005
Location: Suburban Washington DC
Posts: 34
Default

First thing to check is if there is freon in the system. If it hasn't been used in 6 months the seals shrink and allows the freon to leak out.
Reply With Quote
  #3  
Old 05-11-2017, 04:07 AM
Junior Member
Thread Starter
 
Join Date: May 2017
Posts: 4
Default Still wondering about the fuse

Im not sure that the freon is the issue, because there was no change in power when the AC is initiated. When there is freon missing, there is still a change in power, but no cool breeze.
Reply With Quote
  #4  
Old 05-11-2017, 07:41 AM
Senior Member
 
Join Date: Oct 2010
Posts: 4,590
Default

In which fuse box?
Reply With Quote
  #5  
Old 05-22-2017, 08:59 AM
Junior Member
Thread Starter
 
Join Date: May 2017
Posts: 4
Default Fuse is in the Engine Box

Fuse (or lack thereof) is in the Engine Box
Reply With Quote
  #6  
Old 05-22-2017, 10:10 AM
Senior Member
 
Join Date: Oct 2010
Posts: 4,590
Default

That is for a preheater. Not likely to be equipped and not related to your problem.
Reply With Quote
  #7  
Old 05-22-2017, 08:12 PM
Junior Member
Thread Starter
 
Join Date: May 2017
Posts: 4
Default Thanks!

Ok! Thank you for the info!
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1986 240 - missing fuse petergreene Volvo 240, 740 & 940 3 08-25-2015 01:12 AM
245 runs with Main fuel pump fuse missing feor Volvo 240, 740 & 940 0 05-16-2014 06:26 PM
missing air pump fuse haneyde Volvo V70 0 09-20-2010 12:38 PM
Fuse blows with no H.I.D Kit, up the Fuse??? mischief4l Volvo S80 6 09-02-2008 07:13 PM
Missing vacum hose on a `86 240 GL flowerchild Volvo 260, 760 & 960 7 11-18-2004 11:16 PM


Tags
air conditioning, climate element, fuse

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 09:52 PM.