Go Back  Volvo Forums - Volvo Enthusiasts Forum > Volvo Vehicles > Volvo S40
Reload this Page >

S40 1.6D 2008 - Low oil pressure warning light on idle

Volvo S40 The S40 is Volvo's most affordable sedan with all the amenities of a luxury sports car.

S40 1.6D 2008 - Low oil pressure warning light on idle

  #1  
Old 06-30-2019, 03:02 PM
Junior Member
Thread Starter
Join Date: Jun 2019
Posts: 2
Default S40 1.6D 2008 - Low oil pressure warning light on idle

Looks like this problem is hard to solve for me alone.
The car has gone 130 000km.

The car works fine, but the oil light comes on at idle.
When I increase rmp a little, then the light disappears.
The oil level is of course checked and the oil has specifications recommended for this car.

I have dismantled the sump and there doesn't seem to be problems with the strainer and the filter.
I also disassembled the oil pump, but it seems to be okay.

Now I don't know what to do next.

I am grateful for any suggestions that may be helpful in finding the solution!




 
  #2  
Old 07-02-2019, 01:10 PM
Moderator
Join Date: Mar 2012
Location: Ridgefield, CT
Posts: 4,792
Default

a few possible causes 1) issues with the pressure sensor 2) the o-ring/seals in the pump are leaking pressure (sounds like you did the r+r here) 3) the oil pump components are worn and out of spec . It looks like you already cleaned the pick screen etc. As always, make sure you are using the factory recommended oil weight.
 
  #3  
Old 07-02-2019, 02:40 PM
Junior Member
Thread Starter
Join Date: Jun 2019
Posts: 2
Default

Thanks for your feedback mt6127.
How can I check if oil pump components are actually worn and out of spec?
Feels tight when I spin the parts, but I find it difficult to judge when I do not have a reference pump with new parts.
 
  #4  
Old 07-03-2019, 09:36 AM
Moderator
Join Date: Mar 2012
Location: Ridgefield, CT
Posts: 4,792
Default

there are clearance values between the pump components that would probably be listed in a full shop manual or the VIDA/DICE software. But, if you are going to to to the trouble of pulling the pump back out to measure tolerances, you might as well simply install a new oil pump. I'd probably start by replacing the oil pressure sensor first, then consider a Seafoam treatment for the oil to see if that removes any gunk and helps restore pressure at idle. If that doesn't help then you probably should put in a new oil pump with new seals/o-rings etc. I am also assuming you followed standard procedures for priming the oil pump upon its reinstall as well.
 

Last edited by mt6127; 07-03-2019 at 09:38 AM.
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bydand
2001-2013 model year XC70
45
04-20-2017 12:20 AM
Languid
2001-2013 model year XC70
18
08-02-2016 11:11 AM
ted104
Volvo S60 & V60
6
07-29-2016 10:12 PM
brettboze
Volvo S80
2
03-26-2012 06:25 PM


Thread Tools
Search this Thread
Quick Reply: S40 1.6D 2008 - Low oil pressure warning light on idle


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.