Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

2000 Volvo S80 Acceleration Engine Problems

  #1  
Old 02-07-2010, 11:04 AM
Junior Member
Thread Starter
Join Date: Nov 2008
Posts: 2
Default 2000 Volvo S80 Acceleration Engine Problems

Hello Everyone,

I have a 2000 volvo s80 with approximately 140K miles on it. I am having acceleration and/or engine problems, I just replaced my battery and when I went to drive, the car would not accelerate properly. What I mean by this is that, it accelerates slowly but when I try to accelerate real quickly by flooring the pedal, the engine will not exceed 4500 rpm and I have to wait for the rpms to drop back down to idle before I can then SLOWLY accelerate. When the engine hesitates there is no acceleration until I wait for the rpms to drop back to idle. I thought it may be a transmission problem but I put the car in park and when I hit the gas, it does the same thing, the engine hesitates and sometimes even goes from 1500 to 3000, drops and does that repeatedly. I had the car hooked up and the codes came out as P136 and P156 which relate to the oxygen sensors I believe. This problem only started to occur after I replaced the battery...? Has anyone had this problem? Any help or suggestions will be greatly appreciated!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
volvorecycle
Volvo XC70
1
07-22-2015 07:44 PM
Aspireh
Volvo S70
5
07-20-2013 01:48 AM
BlueCracka
Volvo S60 & V60
0
01-14-2013 12:49 PM
SammyZ
Volvo S80
7
04-05-2007 11:05 PM


Thread Tools
Search this Thread
Quick Reply: 2000 Volvo S80 Acceleration Engine Problems


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.