Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

2001 s80 t6

  #1  
Old 08-18-2013, 06:06 PM
Junior Member
Thread Starter
Join Date: Aug 2013
Posts: 10
Default 2001 s80 t6 need help instrument cluster dead engine cuts out

Hi everyone I am having trouble with my s80. some times it wont start if I try a few times it will usually start but then the tach and speedo are out as well as engine temp and the engine cuts in and out . sometimes it is fine... I changed the fuel pump relay and it seemed fixed for a hour but went right back to the same condition. yesterday I unhooked the positive cable and let it sit for a bit hooked back and drove fine for 30 miles went home ate dinner went out and it woulnt start and when it did no gauges? today I got s p1630 code out of it but also have had all sorts of different messages as well..

transmission service required
abs failure
fuel cap loose

so lost please help!
 

Last edited by jeffs80s; 08-18-2013 at 06:29 PM.
  #2  
Old 08-19-2013, 07:54 PM
Former Sponsor
Join Date: Feb 2013
Posts: 86
Default

Have you had your battery and alternator tested yet?
 
  #3  
Old 08-20-2013, 01:41 PM
Junior Member
Thread Starter
Join Date: Aug 2013
Posts: 10
Default

no I will check it tonight. Thank you.
 
  #4  
Old 08-22-2013, 08:14 PM
Junior Member
Thread Starter
Join Date: Aug 2013
Posts: 10
Default

charging system checked out fine. any other thoughts?
 
  #5  
Old 10-02-2013, 08:20 PM
Junior Member
Join Date: Jun 2012
Posts: 19
Default

Sounds like the old throttle body (ETM) dirty thing. Funny story. When I bought my 2002 S80 T6 from a used car dealer with 150K on it, service code came up within a day that the ETM needed replacing. The dealer and I wound up splitting the cost and the shop where he had most of his work done did the job. The car ran fine for over a year. Then it started the old difficult start, idle surging and general lack of power thing (no codes BTW). I replaced fuel filter and spark plugs to no improvement. Finally decided to tackle the throttle body cleaning project. As soon as I reached up to take the intake hose off, it fell off. Seems the tech who replaced in over a year ago got in a hurry and didn't get the back side of the hose all the way around the pipe and it bent the hose to the inside so badly that I couldn't bend it back. I took a razor blade and cut the bent part off, put it back on the throttle body and tightened the clamp up tight and problem solved! Anyway, if you want to tackle the throttle body cleaning, there's one or two good youtube vids which show how to do it. Good luck!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Subvol
For Sale / Trade
0
12-11-2011 06:56 PM
auto325
Volvo V70
4
12-10-2010 07:47 AM
schott1984
Volvo V70
2
09-24-2010 09:15 PM
LarryNH914
Volvo S40
2
08-12-2010 10:09 PM
sk36
Volvo S80
5
08-09-2007 09:59 PM


Thread Tools
Search this Thread
Quick Reply: 2001 s80 t6


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.