Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

99 s80 non-turbo several questions

  #1  
Old 06-18-2014, 08:27 AM
Junior Member
Thread Starter
Join Date: May 2014
Location: West Virginia
Posts: 7
Default 99 s80 non-turbo several questions

Purchased this car 2 months ago. Approx 184k miles.

I had a lot if issues pointing to the ABS module. I pulled it and it was way messed up, clearly amateur repair. Ordered a pull on ebay, advertised as working, installed it. It stopped freaking out as much, but now it's doing it again. About to order an actual refurb. I have reflow equipment at my house but haven't been able to find a good clear picture guide to doing it myself, so I figure why bother.

However, I'm also getting a few new errors that I HOPE are attributable to the ABS module as well---specifically "Service Power Steering" and "Service Transmission", "Output Speed Sensor Circuit No Signal", as well as a P1618 which appears to be "diagnostic trouble code in another control module, possibly the heater on the o2 sensor? Transmission and PS codes are intermittent. (Actual codes: P0722, P0036, P0138, P1633, P1818, and P0455, which I'll discuss below.) PS is making some noise. Will check levels, were fine 1200 miles ago.

It's also had a Bank 1 Sensor 2 voltage high code since I purchased it, apparently that light has been on for some time. Fuel mileage is mid-20's, however I do live in mountains. Car feels a bit sluggish. According to this pic, Bank 1 Sensor 2 is pre-cat, yes? I believe appropriate Bosch PN is 16198? Is there something else I should try first? I read something about cleaning the MAF sensor, that's the next thing to look up.

I'm also getting the P0455, which says "evaporative emission control system leak detected (gross leak)". Had this before, checked vacuum lines (I believe two were reversed in the air intake box), fixed, and it went away. Now it's back. Any ideas on this one? Is there a guide anywhere about which line goes where in the airbox?

Car runs very well. A little slow on the takeoff, but cruises at ~70mph no problem at 2200-2500 rpm. Just did a thousand miles in it, two kayaks on the roof and a trunk full of camping gear, and no problems. Oddly the cup holder got very warm (transmission?) but the cargo box did not, neither did the housing. Very weird.

Sorry for the long thread, any help is appreciated!
 
  #2  
Old 06-18-2014, 07:41 PM
Senior Member
Join Date: Oct 2010
Posts: 5,034
Default

-The power steering does not set any codes.

-P1618 is stored because there is a code in the TCM. Likely related to the P0722.

-I would replace Bank 1, Sensor 2 oxygen sensor because of the heater circuit code. It may take care of the other O2 sensor codes as well. Sensor 2 is post cat.

-P0455 cannot be set by the two small vacuum lines on the airbox. It's either a leak in the evap system or a bad leak detection pump. Might need a software update, too.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
paulmer
Volvo 240, 740 & 940
4
04-14-2010 09:48 PM
lordhowe
Volvo S70
7
08-08-2007 01:20 PM
Psaboic
Volvo 850
18
04-29-2007 03:12 PM
GrantXGoTerps
Volvo S40
3
12-29-2006 10:09 PM


Thread Tools
Search this Thread
Quick Reply: 99 s80 non-turbo several questions


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.