Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

Coolant question

  #1  
Old 02-15-2009, 10:23 PM
Senior Member
Thread Starter
Join Date: Dec 2008
Location:
Posts: 452
Default Coolant question

I have a crack at the top of the coolant overflow resevoir where the hose connects, the bottle needs to be replaced. i cannot get to this for about a month and a half.

the coolant seems to be slowly evaporating or leaking out. cannot tell for sure... ...i dont know the history of my volvo so dont know what coolant is in there now

i keep getting the low coolant error message on the dash at cold start up that dissapears after the coolant warms up and expands enough for the message to go away

i have nissan long life coolant remaining from my other car,the nissan coolant is green but seems darker than the volvo coolant wondering if i can mix that 50/50 and refill the reservoir for now until i get a replacement coolant reservoir would it damage the waterpump or anything else ??
 

Last edited by andrei3333; 02-15-2009 at 10:25 PM.
  #2  
Old 02-16-2009, 06:13 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default

The Green coolant should be fine. Usually all the Green stuff is pretty much the same.
 
  #3  
Old 02-16-2009, 07:11 PM
Senior Member
Join Date: Jan 2008
Location: Tampa, FL
Posts: 879
Default

I just bought a bottle of Prestone green coolant for $10 and got $5 back by rebate.. not a bad deal. Just needed it for a top up, but I don't think they sell antifreeze is convenient sizes..

Its so much better to buy the full concentrate and then dilute yourself...
Regular bottle = $10
50/50 premixed = $8.. shouldnt it be 5? I'm fairly certain that water doesnt cost $3...
 
  #4  
Old 02-16-2009, 07:48 PM
Capo Cam's Avatar
Senior Member
Join Date: Jan 2008
Location: Dayton, OH
Posts: 463
Default

Originally Posted by tech View Post
The Green coolant should be fine. Usually all the Green stuff is pretty much the same.

That's what I've been using also. unfortunately for me I have to buy a bottle every 3-4 weeks or so because our '99 S80 has a crack in the plastic below the resivoir tank. I need to start shopping junk yards soon. I probably could have bought 3 of them by now with all the coolant i've invested in.
 
  #5  
Old 02-16-2009, 10:12 PM
Senior Member
Join Date: Jan 2008
Location: Tampa, FL
Posts: 879
Default

Hey killa, try www.uneedapart.com its a link to a load of junk yards, so see if they can pick up the part for you...
worth a shot..
 
  #6  
Old 02-17-2009, 10:38 PM
Capo Cam's Avatar
Senior Member
Join Date: Jan 2008
Location: Dayton, OH
Posts: 463
Default

Originally Posted by nicolaselias View Post
Hey killa, try www.uneedapart.com its a link to a load of junk yards, so see if they can pick up the part for you...
worth a shot..

Sweet! Thanks for the link. I tried Flea-Bay last night to no avail.
 
  #7  
Old 02-17-2009, 10:42 PM
Capo Cam's Avatar
Senior Member
Join Date: Jan 2008
Location: Dayton, OH
Posts: 463
Default

Can one of you please give me the Volvo Part number or description? When I upgraded my PC I loaded Windows Vista Ultimate and I'm scared to try loading Vadis on it before doing a backup. It would be the plastic tubing that is below the resivoir. I found a few resevoir's on E-gay but none included the tube.
 
  #8  
Old 02-17-2009, 10:49 PM
Senior Member
Thread Starter
Join Date: Dec 2008
Location:
Posts: 452
Default

my vadis works perfectly with vista ultimate 64 bit - go ahead and load vadis

cant picture the part you are desctibing
 
  #9  
Old 02-20-2009, 04:52 PM
Capo Cam's Avatar
Senior Member
Join Date: Jan 2008
Location: Dayton, OH
Posts: 463
Default

Originally Posted by andrei3333 View Post
my vadis works perfectly with vista ultimate 64 bit - go ahead and load vadis

cant picture the part you are desctibing
Cool, I will load her on there tonight. Thanks for the info. I forget the passwords and login though (it's been awhile since I used it). I think it was "admin" or "administrator"?
 
  #10  
Old 02-20-2009, 05:16 PM
Senior Member
Thread Starter
Join Date: Dec 2008
Location:
Posts: 452
Default

the original password that ships with vadis ?
ill see if i still have the readme file
 
  #11  
Old 02-20-2009, 05:49 PM
Senior Member
Join Date: Dec 2008
Location: Rosemount, MN
Posts: 353
Default

The tank is part#30723930
 
  #12  
Old 02-20-2009, 05:50 PM
Capo Cam's Avatar
Senior Member
Join Date: Jan 2008
Location: Dayton, OH
Posts: 463
Default

Originally Posted by andrei3333 View Post
the original password that ships with vadis ?
ill see if i still have the readme file

Thanks again. Don't worry about it. I realized after I unzipped it that it was in my readme.txt file ... lol ... Thanks again. I am getting ready to install so if anything breaks I am holding you fully responsible ... j/k ... lol
 
  #13  
Old 02-20-2009, 05:54 PM
Capo Cam's Avatar
Senior Member
Join Date: Jan 2008
Location: Dayton, OH
Posts: 463
Default

I know this sounds like I am a real hillbilly but do you think that I would be okay to use a hot glue gun on the small crack that I have in the downtube until I get a new / used one? One of the mechanics at work (motorcycle mechanic) suggested trying that as a temporary fix until I get the new one. I know this sounds pretty dumb but I thought "it just may work temporarily". It's just a small crack and I would be using the glue on the outside of the plastic tube not on the inside.
 
  #14  
Old 02-20-2009, 05:57 PM
Capo Cam's Avatar
Senior Member
Join Date: Jan 2008
Location: Dayton, OH
Posts: 463
Default

Originally Posted by JTapper View Post
The tank is part#30723930
Thanks, but it is actually the plastic tube underneath the tank itself that i need. I will be installing VADIS tonight so I should be able to find the # after I get the install on my PC.
 
  #15  
Old 02-20-2009, 06:28 PM
Senior Member
Thread Starter
Join Date: Dec 2008
Location:
Posts: 452
Default

lol

no worries dude

yeah i got some loctite 330 on mine now, its cracked again in a lower spot, and i think i got a guy who is parting out an s80 so i will guy his used tank...

but yeah, if your computer explodes you wount be able to write me any hate mail lol
 
  #16  
Old 02-21-2009, 01:57 AM
Capo Cam's Avatar
Senior Member
Join Date: Jan 2008
Location: Dayton, OH
Posts: 463
Default

Originally Posted by andrei3333 View Post
lol

no worries dude

yeah i got some loctite 330 on mine now, its cracked again in a lower spot, and i think i got a guy who is parting out an s80 so i will guy his used tank...

but yeah, if your computer explodes you wount be able to write me any hate mail lol

Oh yes I will, this is only 1 of my 5 PC's ... lol ... you know I'm just messin around ... It's actually installing as I type this, about 70% complete, I forgot how darn long and massive the program was! Good thing when I upgraded I went with a 1 TG (1000 gigabite) hard drive. I don't think I will ever be able to fill this HD up .. lol
 
  #17  
Old 02-21-2009, 03:05 AM
Capo Cam's Avatar
Senior Member
Join Date: Jan 2008
Location: Dayton, OH
Posts: 463
Default

Got it loaded and the PC is still up and running..lol. Found the part I need #30680924 Filler Hose. I just google'd it and I could have bought it new for the price of 1 container of coolant...go figure!
 

Last edited by Capo Cam; 02-21-2009 at 03:09 AM.
  #18  
Old 02-21-2009, 11:47 PM
Capo Cam's Avatar
Senior Member
Join Date: Jan 2008
Location: Dayton, OH
Posts: 463
Default

I figured it out today. After a closer look it was the rubber hose that comes off the bottom of the resivoir that was leaking. Obviously someone had tried to repair it before with an el-cheap-o hose clamp and that is where the leak was coming from. It was leaking down onto the pipe I was talking about (the one I thought was cracked). So I went to Autozone and spent a whopping $1.36 on a new hose clamp, cut about a quarter inch off the rubber hose where the hole was, slid the hose back onto the resivoir elbow on the bottom and tightened down the new hose clamp. Presto, no more leakage ::knock on wood::
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
cmayo313
Volvo 850
14
03-18-2011 12:09 PM
Ahmed
Volvo S80
4
08-30-2009 01:58 PM
timk
Volvo S70
4
11-16-2007 08:33 PM


Thread Tools
Search this Thread
Quick Reply: Coolant question


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.