Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

Oh great....more problems.

  #1  
Old 12-12-2006, 12:48 AM
Thread Starter
Join Date: Nov 2006
Location:
Posts: 97
Default Oh great....more problems.

Apparently, my s80 disliked its run down the track when I took it down to the drag strip....

The day after I was at the track, the check engine light with the "engine system service required" comes up. I figured it was nothing, and I borrowed my friend's OBDI diagnostic handheld and plugged it into the diagnostic port to reset it (I figured that mabye I just ran too much air into the intake system or something). According to the tester, the reason for the error code was that it had something to do with the Mass Airflow Sensor. However, the next day while I'm driving...the same check engine light and message comes up.

I've nothing to the factory intake system except add a K&N Filter, which I highly doubt is the problem.

Did I hurt something when I went down the track? I've been trying to reset it every time it comes up with my friend's diagnostic tool, but it won't go away.

Ideas? The car is running fine.

Oh, now another problem: my electric fans won't go off! They stay on for a good 5-10 minutes after the car is turned off and the ignition is out. Why is this? It's really concerning me.
 
  #2  
Old 12-12-2006, 12:51 AM
Thread Starter
Join Date: Nov 2006
Location:
Posts: 97
Default RE: Oh great....more problems.

oops. quoted my own post by accident/
 
  #3  
Old 12-12-2006, 01:31 AM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: Oh great....more problems.

I doubt you hurt anything maybe remove the Mass flow sensor and clean it.

The cooling fan will come on after the car is off if it sees the temp at a certain temp.

Is the Mass flow code the only one coming up?
 
  #4  
Old 12-12-2006, 01:54 AM
Thread Starter
Join Date: Nov 2006
Location:
Posts: 97
Default RE: Oh great....more problems.

No, there are about 3 others, which are the following:

1.) Engine System
2.) ABS
3.) SRS Airbag Service Immediately
4.) STC

And the engine is running fine, when I'm driving the temp gauge is dead smack in the middle.....so I see no reason why the fans should be running asfterwards. It would be fine if the fans ran only once and awhile, but now it's EVERY TIME I turn the car off.
 
  #5  
Old 12-12-2006, 08:18 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: Oh great....more problems.

Could be a bad coolant temp sensor or maybe a bad fan.

You need to have all codes pulled.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
akabond
Volvo S80
7
05-28-2011 08:17 PM
gordon368
Volvo S80
2
06-06-2009 03:01 AM
flamejet
General Volvo Chat
2
09-09-2006 02:48 AM
nick54
Volvo S80
10
04-24-2006 12:37 AM


Thread Tools
Search this Thread
Quick Reply: Oh great....more problems.


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.