Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

Transmission spline play?

  #1  
Old 10-26-2010, 08:34 AM
Member
Thread Starter
Join Date: Dec 2009
Posts: 70
Default Transmission spline play?

I just replaced both axle assemblies in my 02 S80 and noted some play in the spline that is inside the transmission that the driver's side axle is fitted to. Does anyone know if this is okay or should it not have any play to it? I do notice a slight knock when I jab at the gas peddle and it sounds like it could be this component hitting transmission wall. I wonder if a bearing has come out of place on this spline diff axle. The entire front end of car has basically been replaced so it is tight as a drum. Any thoughts?
 
  #2  
Old 10-26-2010, 08:37 AM
Member
Thread Starter
Join Date: Dec 2009
Posts: 70
Default

FYI...the transmission also has been rebuilt about 60k ago
 
  #3  
Old 10-26-2010, 07:13 PM
Senior Member
Join Date: Jul 2009
Posts: 275
Default

It will have some play. I bet you need a new transmision mount.
 
  #4  
Old 10-27-2010, 07:04 AM
Member
Thread Starter
Join Date: Dec 2009
Posts: 70
Default

the torque rod mount under the motor/trans?
 
  #5  
Old 10-27-2010, 04:12 PM
Senior Member
Join Date: Jul 2009
Posts: 275
Default

Yes, that's the one.
 
  #6  
Old 10-27-2010, 06:18 PM
Member
Thread Starter
Join Date: Dec 2009
Posts: 70
Default

I have looked at the torque mount recently when I did my transmission fluid and filter change but it looked like the rubber bushings where only slightly cracked not enough to create a lot movement. Maybe it is moving more then thought. So you have seen some play in the spline that comes out of the driver's side transmission because I really thought that was it but I could be wrong. Thanks again for your insight.
 
  #7  
Old 10-27-2010, 08:50 PM
Senior Member
Join Date: Jul 2009
Posts: 275
Default

I did replace my axle with a rebuilt one while I had things apart. But it didn't make the car shift quieter. But replacing that torque mount did make a difference. And mine looked good also.
 
  #8  
Old 10-27-2010, 09:38 PM
Member
Thread Starter
Join Date: Dec 2009
Posts: 70
Default

but you do remember the spline on the transmission had noticeable play?
 
  #9  
Old 10-28-2010, 04:03 PM
Senior Member
Join Date: Jul 2009
Posts: 275
Default

Noticeable? I know that there was movement but how much I can't recall. It defimitely wasn't stiff.
 
  #10  
Old 10-29-2010, 07:26 AM
Member
Thread Starter
Join Date: Dec 2009
Posts: 70
Default

Thanks. As long as you remember some play in it I am comfortable that it is fine and I must have movement in the engine. Probably a motor or torque mount. I will have to look more closely there.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Catchincotton
Audio/Visual Electronics
13
07-06-2016 10:02 PM
VolvoDriver
Volvo 240, 740 & 940
3
10-07-2006 03:02 PM
Ebolavoodoo
Volvo S80
1
09-29-2006 01:04 PM
cbatterman
Volvo S80
1
04-08-2006 02:42 PM


Thread Tools
Search this Thread
Quick Reply: Transmission spline play?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.