Volvo XC70 This wagon/SUV crossover offers the capabilities of an SUV without SUV size.

04 XC70 Front lowbeam out, CHECKED ALL fuses

  #1  
Old 07-12-2008, 02:49 PM
Thread Starter
Join Date: Jul 2008
Posts: 2
Default 04 XC70 Front lowbeam out, CHECKED ALL fuses

My 04 XC70 front passenger low beam went out the other day. I checked the bulb that was replaced about 5 months ago, and all is fine. I took out the right low beam and tried, still nothing. I've checked ALL the fuses under the hood and in the drivers side door and none are blown.

Any ideas?

MUCH thanks!
Paul
 
  #2  
Old 07-13-2008, 09:19 AM
Psaboic's Avatar
Super Moderator
Join Date: Jan 2006
Location: SW, WA
Posts: 2,225
Default RE: 04 XC70 Front lowbeam out, CHECKED ALL fuses

Headlight relay maybe??
 
  #3  
Old 07-13-2008, 09:24 AM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: 04 XC70 Front lowbeam out, CHECKED ALL fuses

Are they HID's or regular bulbs? If it is the HID's the ballast might be bad.
 
  #4  
Old 07-14-2008, 08:26 AM
Psaboic's Avatar
Super Moderator
Join Date: Jan 2006
Location: SW, WA
Posts: 2,225
Default RE: 04 XC70 Front lowbeam out, CHECKED ALL fuses

Good point! I forgot about possible HID's. Guess my CRS is acting up again <grin>
 
  #5  
Old 07-15-2008, 03:16 PM
Thread Starter
Join Date: Jul 2008
Posts: 2
Default RE: 04 XC70 Front lowbeam out, CHECKED ALL fuses

They are HID bulbs, I'll check the ballast. A good way to check to see if they are bad?

Thank YOU!
 
  #6  
Old 07-15-2008, 07:54 PM
Senior Member
Join Date: Apr 2007
Location:
Posts: 100
Default RE: 04 XC70 Front lowbeam out, CHECKED ALL fuses

swap it with the other one and see if it works.
 
  #7  
Old 07-15-2008, 08:04 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: 04 XC70 Front lowbeam out, CHECKED ALL fuses

ORIGINAL: b5254t

swap it with the other one and see if it works.
+1
 
  #8  
Old 08-01-2008, 12:21 PM
Join Date: Jul 2008
Posts: 3
Default RE: 04 XC70 Front lowbeam out, CHECKED ALL fuses

I noticed that i've been going through head lights about every 4 to 5 months thought it was odd but thought again because of the day time running light there are always on. common or uncommon?
 
  #9  
Old 06-25-2011, 09:27 AM
Junior Member
Join Date: Oct 2010
Location: Utah
Posts: 8
Default

I have this similar problem on my 03 xc70. I replace the drivers side light almost every 5 months. I will check the fuses but aside from that I am not sure what else to do. Any help?
 
  #10  
Old 08-07-2011, 08:26 AM
Junior Member
Join Date: Aug 2010
Posts: 12
Default Volvo XC70 oem ballast fail

Originally Posted by frusyks View Post
They are HID bulbs, I'll check the ballast. A good way to check to see if they are bad?

Thank YOU!
Hey, Man, the oem ballast for your car is this:
Wish can help you.

Good luck.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Akaly
Volvo S80
0
06-29-2011 12:09 PM
KeithS60&V70T5
Volvo S60 & V60
2
03-22-2011 10:48 PM
jajulian
Volvo S40
4
11-30-2010 09:59 AM
ojala
Volvo S80
0
07-03-2005 10:20 PM


Thread Tools
Search this Thread
Quick Reply: 04 XC70 Front lowbeam out, CHECKED ALL fuses


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.