General Volvo Chat Post Your Questions And Comments on any of Volvo's many models.

Weber install on 1982 240

  #1  
Old 08-26-2018, 09:19 AM
Junior Member
Thread Starter
Join Date: Dec 2016
Posts: 3
Default Weber install on 1982 240

I am installing a Weber 38 DGAS on a 1982 240, 2.1, and have eliminated the Jetronic fuel injection and related sensors...
I replaced the Volvo elec. fuel pump with a Carter low pressure elec. pump....and using a fuel pressure regulator to deliver 2.5 lbs. of fuel pressure to the Weber.
After unplugging all the sensors, etc. from the Jetronic, I turned on the ignition and have No power to Fuel pumps, and after jumping the fuel pump, With KEY ON, I have power on both coil terminals, . but evidently no spark when cranking the engine..
I'm trying to figure out where I lost power feed ... and How to either trick the ECU and use the Volvo ignition etc. or eliminate it..?????

All the wiring to air valve etc. is still hanging in the engine compartment, as I didn't want to cut out any wiring before I had the car running, and could determine what I still needed to have it run....So Much for that Idea...
Any Ideas???
Thanks
 

Last edited by DrDobler; 08-26-2018 at 03:42 PM. Reason: update
  #2  
Old 08-28-2018, 03:06 PM
Member
Join Date: Jul 2018
Posts: 87
Default

I'm just guessing here. There's a micro switch on the throttle body that turns off the injectors when you close the throttle so you don't get a back fire when decelerating. I wonder if it also turns off the spark? The system shouldn't affect start up and idle though, but depending on what you disconnected, the computer may not know the car is sitting still.
 
  #3  
Old 08-28-2018, 06:02 PM
Junior Member
Thread Starter
Join Date: Dec 2016
Posts: 3
Default

After talking to a friend, the cause may be the CHEESY aluminum foil that grounds the Hall signal plate in a Chrysler distributor.
Evidently the sensor not only triggers the ECU to cause the coil to spark, but also sends the switch current to the fuel pump relay as soon as the starter cranks the engine...
Since it is exhibiting Both these issues... no fuel pumps and no spark.... I looked at the foil on the Distributor plate and its torn and tattered where it should tuck under the cap and be grounded to the distributor housing....
I'll attach a new piece of foil to it tomorrow and try again,,,,,( I had the cap and rotor off while replacing the head etc, and must have torn the Ultra fragile foil strip inadvertently....)
I'm hoping that is the cure....
Thanks,
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
amazon2
All Other Volvo's
0
05-27-2016 08:25 PM
SC Surfer
All Other Volvo's
0
01-19-2016 03:01 PM
amazon2
Volvo 240, 740 & 940
5
04-14-2011 08:44 PM
rick2443
General Volvo Chat
0
07-05-2010 03:49 PM
soapboxhero
Volvo 240, 740 & 940
2
01-21-2006 12:56 AM


Thread Tools
Search this Thread
Quick Reply: Weber install on 1982 240


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.