Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

engine system service urgent

  #1  
Old 11-06-2012, 10:38 AM
Junior Member
Thread Starter
Join Date: Nov 2012
Posts: 5
Default engine system service urgent

2004 Volvo S80 T6 Just replaced all six spark plugs and #6 ign coil that had failed. Also replaced air filter and cleaned MAS with electonic spray.
This work was undertaken due to 12 miles into first ride after Sandy(NJ), the CEL came on and when stopped at destination (2 more miles), the idle was extremely rough and CEL started flashing. When restarted, still rough idle, but a steady CEL. Neutral was not as rough as drive. After starting to drive, acceleration was a problem, but would cruise steady at 35, 40 MPH. CEL would flash for way less than a min( 5-10 sec) when first accelerating then go steady.
So... starting car after replacing noted parts, it idled smooth and seemed fine. I let it idle for about 5 mins while i got ready to test drive. First press of gas pedal (in nuetral)resulted in minimal RPM rise. When put in drive, smooth engine but sluggish on power. Then in text window came "engine performance low" . Stopped and restarted and then message said "engine system service urgent". Any comments on what changing the noted parts would contribute to message received. Does car have to be "reprogrammed", for lack of a better word. Have I created problem requiring Dealer to "reset" anything? Any comments or advice would be greatly appreciated. First time on Volvo. Lots of older VW Passat, Jetta and US car work done over the years. I've been a shade tree mech for all my cars over the last 40 years, just never on Volvo. Especially 2004! (New to me) Thanks again in advance for any comments.
 
  #2  
Old 11-07-2012, 10:25 AM
gabyman97596's Avatar
Senior Member
Join Date: Feb 2007
Location: Kissimmee,FL
Posts: 352
Default

I would first check for any loosen coil plugs, but looks like another coil went out.
 
  #3  
Old 11-07-2012, 10:37 AM
Junior Member
Thread Starter
Join Date: Nov 2012
Posts: 5
Default Thanks

Thanks for reply.
 
  #4  
Old 11-08-2012, 01:26 PM
Junior Member
Thread Starter
Join Date: Nov 2012
Posts: 5
Default reset

Disconnected battery over night. Did remote locks , etc., prior to starting. Started car and it idled fine. CEL was off and the only message said time for regular service. Drove the car gently for 3-4 miles and then I tried a hard acceleration and the car did not respond although the tach rose above 2000. Let off gas and reduced engine performance message came on. Limped back home and at idle was still smooth. After restarting car, messages were clear and no CEL! Took off on another test drive and went fine for 3-4 miles and reduced eng perf returned when gas was pressed for accelerating from 35MPH. It appears plugs, coils, and air filter are not the problem. ???
 
  #5  
Old 11-09-2012, 10:43 AM
Junior Member
Thread Starter
Join Date: Nov 2012
Posts: 5
Default dealer

Drove car 12 miles to dealer. 1/4 mile from house reduced performance message came on. Pulled over and turned off for couple minutes. Restarted and car ran all the way to dealer although this was a cruise at 30-40 MPH. No power when pushing gas pedal with engine above 2000RPM. Good idle at stops but take off was just plain lack of power. Never got any other messages. Dealer diagnosed and found three codes. Turbo, Thermostat!,and engine sys. No #codes provided yet. Wants $177 just to take off pipes and plastic covers to investigate further. I'm getting twitches in lower region as dealer grip seems to increase. I said go for it.
 
  #6  
Old 11-11-2012, 07:37 AM
Junior Member
Thread Starter
Join Date: Nov 2012
Posts: 5
Default power restored

vida connect... codes ECM-201A Thermostat, ECM-6814 Turbo, ECM-982A Engine control.
Tech removed obstruction in intercooler, software update.
Codes cleared and s80 t6 runs like normal.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
robingichuhi
Volvo S80
3
02-22-2017 04:34 PM
davidfoster
Volvo S60 & V60
2
07-04-2007 05:35 PM
Sssnake
Volvo S80
1
01-10-2007 12:26 PM
rjhunter
Volvo S80
11
05-26-2005 01:05 PM


Thread Tools
Search this Thread
Quick Reply: engine system service urgent


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.