Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

on going 2000 S80 T6 problems/issues

  #1  
Old 04-27-2013, 11:36 PM
Junior Member
Thread Starter
Join Date: Apr 2013
Location: Central Arizona USA
Posts: 7
Default on going 2000 S80 T6 problems/issues

With all the following, can anyone give me an idea as to how much further in this “Volvo S80 T6” tunnel of darkness I might expect to go before I see some light?! What other super common issues might I expect to have? Please share anything I have not listed…..promise I won’t cry.
Repairs made to my Volvo 2000 S80 T6 with 129000 miles
Rear brake pads
Broken fuel pump plastic housing
Squeaky glove box latch
Clunky sunroof glass
Drive axles right and left
Control arms w/bushings
Sway bar links
Turbo boost solenoid
New transmission
Headlight lens right side
Most vacuum hoses due to rot

Maintenance done as follows:
Spark plugs changed
Fuel filter replaced
Transmission filter and fluid twice before replacing transmission

Accessories done as follows:
Custom sheepskin seat covers
Wood grain look dash kit
Leather (wrapped) steering wheel cover
Current issue to address is no oil pressure message, plan of attack is to drop oil pan and replace o-rings and clean tubes, screen, etc.
 
  #2  
Old 04-30-2013, 09:44 PM
Junior Member
Thread Starter
Join Date: Apr 2013
Location: Central Arizona USA
Posts: 7
Default

What we found once we dropped the oil pan. A very bad o-ring on the tube to the oil filter housing.
 
Attached Thumbnails on going 2000 S80 T6 problems/issues-img_20130430_185618_401.jpg  
  #3  
Old 05-05-2013, 12:27 PM
CPB
CPB is offline
Junior Member
Join Date: May 2013
Location: Northern Virginia
Posts: 2
Default

Does it leak from the oil filter housing or just creates a lack of oil pressure in the the filter?
 
  #4  
Old 05-05-2013, 09:17 PM
Junior Member
Thread Starter
Join Date: Apr 2013
Location: Central Arizona USA
Posts: 7
Default

it just caused no oil pressure. which triggered the message "no oil pressure stop engine" and after researching that warning through forums we concluded that it might be the oil pump or o-rings. Glad it was the latter.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dobrosailor
Volvo 240, 740 & 940
13
01-16-2010 10:21 PM
dobrosailor
Volvo 240, 740 & 940
8
01-12-2010 06:20 AM
daver80
Volvo 240, 740 & 940
2
06-29-2009 03:01 PM
XSive
Volvo 240, 740 & 940
3
06-20-2007 05:15 PM


Thread Tools
Search this Thread
Quick Reply: on going 2000 S80 T6 problems/issues


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.