Go Back  Volvo Forums - Volvo Enthusiasts Forum > Volvo Vehicles > Volvo S80
Reload this Page >

I think I found the main problem with the transmission.

Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

I think I found the main problem with the transmission.

  #1  
Old 05-02-2018, 03:00 PM
Banned
Thread Starter
Join Date: Aug 2016
Posts: 156
Default I think I found the main problem with the transmission.

Hello everyone just wanted to give everyone an update on my 00 Volvo S80 T6.

If you've seen some of my other posts you probably saw that I was having some problems with the transmission. One of the problems was the torque converter clutch engaging in and out . Well with further research I also found that I had a code for the brake pedal position sensor .
So I figured that if the sensor was bad it could cause some confusion with the transmission.
So I disconnected the brake pedal position sensor and now everything is shifting great. I will keep you posted as I need to do more driving to make sure.
But anyway does this make sense? Any input will be helpful.
Thank you!
 
  #2  
Old 05-03-2018, 04:08 PM
Banned
Thread Starter
Join Date: Aug 2016
Posts: 156
Default Update

Originally Posted by e.mence440 View Post
Hello everyone just wanted to give everyone an update on my 00 Volvo S80 T6.

If you've seen some of my other posts you probably saw that I was having some problems with the transmission. One of the problems was the torque converter clutch engaging in and out . Well with further research I also found that I had a code for the brake pedal position sensor .
So I figured that if the sensor was bad it could cause some confusion with the transmission.
So I disconnected the brake pedal position sensor and now everything is shifting great. I will keep you posted as I need to do more driving to make sure.
But anyway does this make sense? Any input will be helpful.
Thank you!
Well did some more driving today and the problem is solved. No slipping at all! And my gas mileage has gone up. I wish I had disconnected the sensor 9 months ago. ( I've had the brake pedal position sensor error since I bought it ) . I may have had a unique situation here. But glad it's finally fixed. Now should I replace that sensor or leave it disconnected?
Thank you.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
J Dubb
Volvo 240, 740 & 940
1
09-08-2013 08:57 PM
keithchapman
Volvo S40
0
12-11-2010 02:23 PM
ibified
Volvo 850
1
07-04-2010 08:27 AM
alkali2010
Volvo S70
1
03-23-2010 08:38 PM
chef
Volvo 850
13
06-27-2008 07:39 PM


Thread Tools
Search this Thread
Quick Reply: I think I found the main problem with the transmission.


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.