Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

loosing power on low gears

  #1  
Old 03-06-2010, 10:36 AM
Junior Member
Thread Starter
Join Date: Mar 2010
Posts: 4
Default loosing power on low gears

I have a 2001 s80 t6. When I come to a stop the car starts to vibrate or skip forward a lil.. and few times died on me when I was on a light or parking lot. starts up just fine and accelerates good.. I was thinking it might be the spark plugs but i have no check engine light or anything.. anyone know what it might be?
 
  #2  
Old 03-06-2010, 03:04 PM
Member
Join Date: May 2009
Location: melbourne, fl
Posts: 86
Default

Your Electronic Throttle Module is bad. You can find a non contact aftermarket ETM repair on the internet that keeps these problems from ever happening again.

http://www.xemodex.com/

i haven't done it yet, but there are YouTube videos where people had positive results, it just costs 600 bucks and i'm not there yet. I have the exact same problems as you right now.
 
  #3  
Old 03-06-2010, 05:27 PM
Senior Member
Join Date: Dec 2008
Location:
Posts: 452
Default

are any of the dash lights on that were not on before ?
 
  #4  
Old 03-07-2010, 01:24 PM
Junior Member
Thread Starter
Join Date: Mar 2010
Posts: 4
Default

thanks... that does sound like the problem, i was thinking that may be the problem cause thats what regulates the rpms and the flow..

No, none of the lights are one, check engine doesn't come on or anything, otherwise I would have just plugged it in and ran diagnostics for it..
 
  #5  
Old 03-07-2010, 01:44 PM
Senior Member
Join Date: Dec 2008
Location:
Posts: 452
Default

dont all the lights come on with a bad etm ? or is that the case with a bad abs module ?
 
  #6  
Old 03-09-2010, 12:51 AM
Junior Member
Thread Starter
Join Date: Mar 2010
Posts: 4
Default

no the lights don't come on for the etm...
 
  #7  
Old 03-09-2010, 11:51 AM
Senior Member
Join Date: Feb 2010
Posts: 171
Default

If the ETM gets bad enough it should throw a code, in fact this is a prequsite for the ETM software recall I believe. Does your inlet manifold have a yellow sticker on the bottom of it?

PCV service and a set of copper spark plugs are worth a try IMO. Maybe consider cleaning the throttle body as well if it is gunked up. ETM failures are a certaintly with the S80's it seems, but still I would be checking the basics first before I go dropping $600 on it. If you dont know when the plugs were done last, you might as well do them. Make sure you gap them to .028". They are super cheap (<$3 each) and usually need to be done every 35K miles, or less depending on how much time you spend on boost
 
  #8  
Old 03-09-2010, 03:54 PM
Member
Join Date: May 2009
Location: melbourne, fl
Posts: 86
Default

the software update was a recall from years ago, it would cover any check engine lights and has most likely been done. as you and i both know by now, the software update is total crap. it gives your car 5,000 more miles at best and most people that get it end up rolling right back to the stealership and getting another new (but broken!) ETM that will fail eventually. if you want to fix your car, never go back to volvo. find yourself a certified mechanic or do the ETM repair yourself (requires you to take it out and send it off, and put it in again, probably 6 labor hours at dealer). the yellow sticker means replacement ETM by the way, no software update gives anything a new colored sticker. I've had the update but no new ETM and mine's still white.
 
  #9  
Old 03-10-2010, 07:55 AM
Senior Member
Join Date: Feb 2010
Posts: 171
Default

Originally Posted by N_Vagrant View Post
the yellow sticker means replacement ETM by the way, no software update gives anything a new colored sticker. I've had the update but no new ETM and mine's still white.
Interesting, very interesting. I guess mine was replaced at some stage then. Hmmm.
 
  #10  
Old 03-10-2010, 12:24 PM
Junior Member
Thread Starter
Join Date: Mar 2010
Posts: 4
Default

On top of the stalling, engine dying on low rpms and vibrating, now my engine light came on. got the "cylinder 4 misfire" code come up.. Is that related to the ETM not working properly or is that a seperate issue?? I'm Planning on exchanging the ETM within a week or 2(and spark plugs, filters) and was wondering if I may also have other issues..
 
  #11  
Old 03-10-2010, 12:45 PM
Senior Member
Join Date: Feb 2010
Posts: 171
Default

Swap the coil (maybe plug too) on cyl# 4 with another one and see if the code moves to that cylinder. If it does, you need to replace that coil (or plug). Im optimistic that a tune up will help.

A misfire code on a certain cylinder is unlikely to be caused by a ETM issue.
 

Last edited by NoLifeTilBoost; 03-10-2010 at 12:53 PM.
  #12  
Old 05-05-2010, 11:21 AM
Junior Member
Join Date: May 2008
Location:
Posts: 4
Default Check engine light with stalling and or "jumping" before stall

I had a similiar problem with my s80-T6 2001 has 212,000. I was told I was experienceing result of of some "blow pass" Oil getting into places it shouldn't. Any way I milked it along until it finally gave out on me last week. I am still waiting on the estimate and declaration of damage. Not sure if Last Rights are in order or an engine swap... any thoughts?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Atlas Shrugged
General Volvo Chat
0
05-08-2015 09:02 PM
elderzap
Volvo 240, 740 & 940
0
11-07-2007 04:58 PM
SpecterV70
Volvo V70
9
07-24-2007 04:40 PM
postdoc99
Volvo S70
1
04-16-2006 11:41 PM


Thread Tools
Search this Thread
Quick Reply: loosing power on low gears


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.