Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

Tech Question

  #1  
Old 12-09-2008, 08:44 PM
Member
Thread Starter
Join Date: Dec 2008
Location: Abington, MA
Posts: 66
Default Tech Question

Tech,

I have replaced my HU-801 i believe in my '00 S80. Once i have put my radio, Climate control module, etc.. back in my information screen on my gauge cluster says " SRS Service Urgent". This had happened previously when i was running wires through my center console. Last time i brought it to my local dealer and they said that it was an erroneous code in the system, and rewrote the code. It was fine up until the install of my new radio. When this service light happened again. I am assuming that it is again an erroneous code in the system. But my question was, does the SRS system run in a circut through the Radio/ Climate Control Module, and is that why this light goes off everytime i disconnect either of those things?

Breandan
 
  #2  
Old 12-09-2008, 09:08 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: Tech Question

It is kind of tied to the systems. The radio is a module in part of a network. Did you install an aftermarket radio?

If so you should really get a software download to remove the OEM radio as a module.
 
  #3  
Old 12-09-2008, 09:40 PM
Member
Thread Starter
Join Date: Dec 2008
Location: Abington, MA
Posts: 66
Default RE: Tech Question

yes i did install an aftermarket radio, i installed an alpine headunit. where would i go about downloading this software to remove the OEM radio as a module?

Breandan
 
  #4  
Old 12-09-2008, 09:41 PM
Member
Thread Starter
Join Date: Dec 2008
Location: Abington, MA
Posts: 66
Default RE: Tech Question

also how would i upload this software to my car?

Breandan
 
  #5  
Old 12-09-2008, 09:50 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: Tech Question

The Dealer will have to do it for you. Or a Volvo specialist shop that is able to do the downloads.
 
  #6  
Old 12-09-2008, 09:52 PM
Member
Thread Starter
Join Date: Dec 2008
Location: Abington, MA
Posts: 66
Default RE: Tech Question

thank you. how much do you believe that will run me?
 
  #7  
Old 12-09-2008, 09:55 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: Tech Question

The software itself should be about $30.00 then between 1/2 hour and 1 hour labor.
 
  #8  
Old 12-09-2008, 09:59 PM
Member
Thread Starter
Join Date: Dec 2008
Location: Abington, MA
Posts: 66
Default RE: Tech Question

thanks
 
  #9  
Old 12-09-2008, 10:01 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: Tech Question

Your welcome anytime.
 
  #10  
Old 12-10-2008, 03:39 PM
Senior Member
Join Date: Mar 2008
Posts: 285
Default RE: Tech Question

Anytime you are going to work with an electrical part on a VOLVO..make sure you DIS-CONNECT the NEGATIVE side of the battery First..then you won't get the SRS Warning on your dash..I know I found out the hard way also....even bought a SRS Erase Diagnostic tool in case I forget again, and since I did that..I will never forget again (Ithink)....
 
  #11  
Old 11-04-2009, 10:49 AM
Junior Member
Join Date: Mar 2009
Posts: 21
Question

Originally Posted by air force rascal View Post
Anytime you are going to work with an electrical part on a VOLVO..make sure you DIS-CONNECT the NEGATIVE side of the battery First..then you won't get the SRS Warning on your dash..I know I found out the hard way also....even bought a SRS Erase Diagnostic tool in case I forget again, and since I did that..I will never forget again (Ithink)....
Hello, I have also found out the hard way. I was wondering where you picked up the srs erase diagnostic tool? I have a 2001 S60, and I installed a aftermarket HU, and forgot to disconnect the negative terminal. Now I also have those problems including this... My climate control works fine except for my heated seats button, and rear defrost button... They don't illuminate or work when pressed. When you push the rear defrost button, I can hear it clicking in the back seat, but it won't come on. The heated seat buttons also do not light up, or do anything when pushed, but the heated seats are permanently on unless I remove the fuses!? Also my mirrors which I thought were heated, no longer work. All of these problems came after the install. I spent $100 on a new climate control panel, and it did nothing. I am lost on what to do... I might have to put back the stock unit, which i'd rather not. Have you ever seen any of these problems?Thanks ahead of time for any help.
 
  #12  
Old 02-01-2014, 05:31 PM
Senior Member
Join Date: Oct 2012
Location: Pennsylvania
Posts: 109
Default

I see that this thread is very old, but Im reading up on this issue and need advice from anywhere I can get it. I just bought a 2002 S80 and the previous owner had just replaced the battery and now the climate control is out as well as the SRS urgent message in the dash. Im wondering if your still on here, what scanner you bought that will clear this code and make the climate control work again. Crossing my fingers. Thanks
 
  #13  
Old 02-02-2014, 12:49 PM
Junior Member
Join Date: Mar 2009
Posts: 21
Default

Originally Posted by ingydrummer View Post
I see that this thread is very old, but Im reading up on this issue and need advice from anywhere I can get it. I just bought a 2002 S80 and the previous owner had just replaced the battery and now the climate control is out as well as the SRS urgent message in the dash. Im wondering if your still on here, what scanner you bought that will clear this code and make the climate control work again. Crossing my fingers. Thanks
*Bump* I still have this climate control issue. My seat heaters work, but the lights on the unit/module it self do not light up. Same thing with the rear defrost button; doesn't light up.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Ahmed
Volvo S70
5
04-13-2006 12:05 AM
reg
Volvo C70
11
04-06-2006 10:01 PM
chriga
Volvo S80
3
01-04-2006 10:04 PM
jpethan
Volvo S80
3
12-20-2005 12:44 AM
revdevil
Volvo 850
5
11-03-2005 01:09 AM


Thread Tools
Search this Thread
Quick Reply: Tech Question


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.