Volvo S70 Made from 1998 to 2000, this sporty model replaced the 850 sedan and instantly became a hit.

'98 S70 GLT...starts...but stumbles/dies

  #1  
Old 03-12-2010, 04:37 PM
Member
Thread Starter
Join Date: Jan 2010
Posts: 35
Default '98 S70 GLT...starts...but stumbles/dies

New issue that just started. Car was running well. Ran it hard for a couple of short distances to see how it was running. The idle began to hunt while slowing down. It's gotten progressively worse. Car will die while slowing down. Starts immediately, but idle just dies. It's like it tries to stabilize...but just keeps loosing rev's and dies.

Thoughts?

Thanks,

Ken
 
  #2  
Old 03-12-2010, 07:46 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default

Have you tried cleaning the idle motor?
 
  #3  
Old 03-12-2010, 09:13 PM
Member
Thread Starter
Join Date: Jan 2010
Posts: 35
Default

Originally Posted by tech View Post
Have you tried cleaning the idle motor?

Hey Tech,

Sure have. Cleaned it about 2 months ago and have driven less than 50 miles.

I just found an old thread that also mentions something about adjusting the throttle switch.
To do this, I'm assuming the throttle body has to be removed. In doing so, will it require replacing any gaskets???
I'm planning to give the throttle body a good cleaning and check the adjustment.

Any other recommendations?

It's weird, the car was running perfectly fine...until I ran it WOT a few times.

I'm beginning to wonder if a vacuum line may have anything to do with this? It's rained all day and no garage to work in. So, hopefully tomorrow I can pop the hood and look at all the basics.

Thanks,

Ken
 
  #4  
Old 03-12-2010, 09:33 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default

On the S70 you should not mess with the adjustment.

Yes try cleaning the throttle body though.
 
  #5  
Old 03-13-2010, 05:16 PM
Member
Thread Starter
Join Date: Jan 2010
Posts: 35
Default

Turned out to be a very easy fix. The bottom hose on the Idle Air Controller slipped off. I had attempted to reuse the Volvo funky clamp and must not have secured it properly. Replaced the clamp with a traditional type unit and all is well.
Unfortunately, it threw a code. So, I guess a trip to AutoZone is in order.

Ken
 
  #6  
Old 03-13-2010, 08:11 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default

Glad all is good now.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rspi
Volvo S70
15
03-26-2014 09:19 AM
960 rookie
Volvo 260, 760 & 960
5
08-08-2012 01:53 PM
estreet1
Volvo S70
8
01-16-2012 01:33 PM
Aux
Volvo S40
6
12-27-2007 03:43 PM
Aux
Volvo S40
3
11-14-2007 10:52 AM


Thread Tools
Search this Thread
Quick Reply: '98 S70 GLT...starts...but stumbles/dies


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.