Throttle Body Replaced - No Software! - Page 3 - Volvo Forums - Volvo Enthusiasts Forum

Go Back  Volvo Forums - Volvo Enthusiasts Forum > Volvo Vehicles > Volvo V70
Reload this Page >

Throttle Body Replaced - No Software!

Volvo V70 Super capacity, super looks, super performance... this wagon turns heads and can still get the job done.

Throttle Body Replaced - No Software!

  #41  
Old 11-07-2011, 06:31 AM
Junior Member
Thread Starter
Join Date: Aug 2010
Posts: 11
Default

.. It's a good idea to check it under load - (think thats already been mentioned here).. Also if the butterfly is restricted at any part of its travel it will confuse the ETM & act as if the pots are bad...

The unit is actually very, VERY well engineered, the only issue is with the potentiometers once this is resolved its fine,

as a basic test -
1. switch on ign
2. Check volts on pin 5&6 of ETM Plug (pref with etm plugged in)
If <11v then check the earth connection (brown wire fixes to block next to air con pump).. if 11v> go to step 3
3. listen to TB - If its making a whineing sound clean & lube it !!
4. If it still throws up codes replace or re-build

Steve
 
  #42  
Old 11-08-2011, 03:30 PM
Senior Member
Join Date: Apr 2011
Location: Sarasota, FL
Posts: 182
Default

if I read your post correctly, you bought another '01 P2 volvo that is showing same symptoms as your other '01 P2 car, correct?
 
  #43  
Old 11-09-2011, 05:46 AM
Junior Member
Thread Starter
Join Date: Aug 2010
Posts: 11
Default

Hi Jda...

No it's a P1.... they both are (2000) - interesting that they both were supplied by the same dealer in 2000 ! .....maybe it was YK2B

... Think the TB on the latest one just need's a clean as its been fine since i stuck my finger in it !

At the time it was faulty i got:-
P0225
P0222
P1670
P1600
P1620
P1610

These have cleared & not returned
 
  #44  
Old 11-09-2011, 09:30 AM
Senior Member
Join Date: Apr 2011
Location: Sarasota, FL
Posts: 182
Default

Originally Posted by Steve 1564 View Post

No it's a P1.... they both are (2000) - interesting that they both were supplied by the same dealer in 2000 ! .....maybe it was YK2B
Steve, you sure like to play with fire

but I am glad that things are working out for you.
 
  #45  
Old 01-16-2012, 02:29 PM
Junior Member
Join Date: Jan 2012
Posts: 1
Default How do you overhaul this without breaking the contacts / green putty?

I bought a 2008 (yellow label) throttle body and found out online it wouldn't work in my 2001 Volvo S60 (white label) because of the software tied to the VIN of the vehicle. So I opened it up as the references show in this posting. I have the new potentiometer resistor films and "fingers" out of the end caps. Here's the issue - how do I take the end caps off the "bad" unit without breaking the contacts, as that green "potentiometer putty" is like glue holding the thing together.

Do you have to break the contacts out, remove all the putty under the top metal tin, the resolder? Or is their an easier way?

I'd rather let someone else do this if so. Don't want to be without my car too long... Thanks!

http://www.ip-wizards.ch/volvo/VEXED...arelli-ETM.pdf
 
Attached Thumbnails Throttle Body Replaced - No Software!-photo_dc67fca3-adb5-6b54-d943-5904359c4428.jpg  
  #46  
Old 03-29-2012, 04:29 PM
Junior Member
Join Date: Mar 2012
Posts: 2
Smile

Hi great thread, very informative

Having same trouble........is it straight forward to check the ground near alt/ac pump or do you have to remove p/s pump, and alt to get to it?
 
  #47  
Old 12-04-2012, 08:38 AM
Junior Member
Join Date: Nov 2012
Posts: 3
Default

Originally Posted by Bobec View Post
The yellow sticker means it had a firmware up date not that it was replaced. As far as recalls go check the internet or right here on the forum

https://volvoforums.com/forum/general-volvo-chat-5/recall-sources-all-models-12721/
I have a similar problem as person above... New ETM & MAF fitted bringing up p0121 & p1609 mostly among others... Think it maybe a wiring fault.. Green wire is showing 12v when ignition on.. Is this right..?? (my baby off the road now but before it got this bad.. Would every now and again idle really rough .. Had to disconnect batterie to clear and run again..!!)
 
  #48  
Old 12-04-2012, 09:15 AM
Junior Member
Join Date: Nov 2012
Posts: 3
Default

Originally Posted by Steve 1564 View Post
Bobec...

Thanks Man,
sorry for the late reply (working away)
You did indeed steer me in the right direction - (batt volt drop ect,) mind you even volvo diagnosed it as the ETM, It was only when i measured the volts at the plug (ex tv so usually just connect the fluke neg lead to the battery) that i found the problem, Guess there's some politics regarding the ETM issue, Mines brand new so works well, but i cant really understand why they didnt use contactless pots.. - and yes your right the Magnetti ETM is very well engineered and should last a very long time even with its wiper pots, and let's be honest if you had a bill for a part that cost say Ģ400 after 100k or so would it seem like a big deal ? I mean it cant be much more expensive than a set of tyers or an exhaust
Still cant help felling sorry for the old boy that i bought it off... not sorry enough to give him any more money of course, but i think i'll add him to my christmass card list

Has anyone sourced the potentiometers ? I can see it being a massive job to change them >?
The bad earth you had was it the one right hand side where rad is... This see to be quite substantial or are you talking about another and where is it located...??
 
  #49  
Old 10-10-2016, 07:15 PM
Junior Member
Join Date: Oct 2016
Posts: 3
Default PAY IT FORWARD - kudos to BOBEC

Originally Posted by Bobec View Post
With all due respect.... You're welcome.

I mean where did you get the supply voltage idea?

Now If you want to help all Volvo owners escape this F&^%ing witch hunt that is going on on Matthew's site you can make it known that bobec from volvoforums steered you in the right direction.
Point well taken SIR, and I mean SIR to everyone who is so very helpful herein.

ETM on my 2001 V70XC causes rpm drop? lights flicker but other than that the wagon runs great.

I expect that this ETM may have a distruptive failure some day so for my part I totally appreciate your expertise BOBEC.

2001 V70XC 155K
 
  #50  
Old 10-11-2016, 05:15 PM
Junior Member
Join Date: Jun 2009
Posts: 16
Default Swapping ETM's from different models & years

I picked up a couple of Yellow label ETM's from the wrecking yards & (for my 2000 S80 2.9l) it has been a plug & play (drive) deal. No faults, codes or driveability issues. I used one XEMODEX ETM from an 03 C70 & it worked great without any issues, faults or driveability problems. Tried 2.8l Turbo ETM with no problems. Not once did I have the software loaded. I also installed one with the "Sacer" contactless mod that I did & it worked. Why is my car working fine when I hear other are having issues? Is it the year or computer of the 2000 S80 that allows me to swap ETM's?
 
  #51  
Old 10-11-2016, 07:49 PM
Junior Member
Join Date: Oct 2016
Posts: 3
Default ETMs from boneyard

Thanks for the 411 GOLD!
Paying OEM prices and labor rates at VOLVO dealer for electronics on a $4,500 16-year-old albeit SWEETHEART of an XC70 - is like a kick in the groin IMHO. Have a blessed day.
 
  #52  
Old 12-19-2017, 12:46 PM
Junior Member
Join Date: Dec 2017
Posts: 2
Default

hello,
I can't see your digram, can you please send it again or just explain it again ? thank you
 
  #53  
Old 08-22-2018, 07:44 AM
Junior Member
Join Date: Nov 2017
Posts: 7
Default

hi sorry to revive this topic but this seems like my problem.
2001 S60 2.0t runs fine until it get to temperature then just bogs down and theres no power anymore, checked all vacuum tubes no leaks (boost is at 0.5 Bar solid) replaced MAF and lambda Probe, cleaned the ETM, checked all plugs and coils, theres no errors in Vadis or in the dash.

but as soon as the engine temperatures gauge reaches the midle, theres no power its like I donīt have a turbo anymore, but it doesn't always does this I recently made a trip 100miles going way I had this symptoms coming back all was good... even installed a Turbo gauge to keep track of this.
at idle the revs are spot on 900rpm +/- with no fluctuation but the engine rocks it self enough to rock the car back and forward.

anyone with a picture of this ground wire? is it hidden?
thanks for any help
 
  #54  
Old 08-22-2018, 10:02 AM
Senior Member
Join Date: Nov 2006
Location: Birmingham AL
Posts: 1,502
Default

You will need a Volvo software equipped scan tool to access the ETM and see if there are codes stored. It does sound like a bad ETM.
 
  #55  
Old 08-22-2018, 01:17 PM
Junior Member
Join Date: Nov 2017
Posts: 7
Default

I did the ETM test in Vadis this is what I came up with:
 
  #56  
Old 11-19-2018, 01:34 PM
Junior Member
Join Date: Nov 2017
Posts: 7
Default

So update on this, bought a "new" ETM with yellow sticker and new gasket tested it and the problem continued, I gave up and went to the dealer, they said that you couldn't use a used ETM on this cars that it had to be a new one and programmed in the car that they would take the old one and refurbish it, total cost about 600€ I didn't believe them so I went to visit a guy that works and refurbishes volvo ETM he tested both ETM's and they were ok tested right in front of me even the software of the yellow ETM was correct for my car so no update needed, he did notice an error on the VVT exhaust sensor, and said that possibly this could be the fault so i took it out and spraid the hell out of it with brake cleaner and the problem just went way!

Later I found a used unit on ebay bought it and left it sitting in degreasser to take all the gunk out and cleaned it really good bought a new gasket and the problem hasn't returned ever since.
total cost about 40€ and a good clean.

I will never blame the ETM again.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
treestone27
Volvo S80
6
04-29-2014 08:40 AM
Danny Reed
2001-2013 model year XC70
9
02-20-2014 02:26 PM
samiam114
Volvo S80
3
10-22-2013 07:52 PM
Radio Flyer
Volvo V70
1
06-05-2009 10:12 AM
kaltek
Volvo S80
17
06-12-2006 11:42 AM


Thread Tools
Search this Thread
Quick Reply: Throttle Body Replaced - No Software!


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.